kernel: add w83627hf-wdt watchdog timer module
authorPhilip Prindeville <philipp@redfish-solutions.com>
Tue, 10 Jan 2017 00:18:21 +0000 (17:18 -0700)
committerJohn Crispin <john@phrozen.org>
Wed, 29 Mar 2017 06:21:09 +0000 (08:21 +0200)
This is a 3rd party chipset which is not present on all Intel
reference designs, so make it a module rather than baked in (this
will also alleviate conflicts with drivers which also detect some
of the same chipsets).

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
package/kernel/linux/modules/other.mk

index 8ea435ed8481734890f0e6c9e05bfa5eca69fa9d..b8b22411b2fcfcd58468c45867c9e079d649e480 100644 (file)
@@ -1018,3 +1018,18 @@ define KernelPackage/tpm-i2c-infineon/description
 endef
 
 $(eval $(call KernelPackage,tpm-i2c-infineon))
+
+
+define KernelPackage/w83627hf-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Winbond 83627HF Watchdog Timer
+  KCONFIG:=CONFIG_W83627HF_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/w83627hf_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,w83627hf-wdt,1)
+endef
+
+define KernelPackage/w83627hf-wdt/description
+  Kernel module for Winbond 83627HF Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,w83627hf-wdt))