build: remove check to nonexistant CONFIG_ENABLE_LOCALE variable and move DISABLE_NLS...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:07 +0000 (15:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:07 +0000 (15:54 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39980

include/package-defaults.mk
rules.mk
toolchain/gdb/Makefile
toolchain/insight/Makefile

index 62ccbb93ef0a8c2f65e7f47855142919f6d5de9b..8f35c3293e6902a9fb732770c679cb37aae4c20b 100644 (file)
@@ -64,6 +64,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
 endif
 
 EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
+DISABLE_NLS:=--disable-nls
 
 CONFIGURE_PREFIX:=/usr
 CONFIGURE_ARGS = \
index 0769a09278270e92bec1c1c24ec9b5fd0e7ad7e9..cc02b91bc9c8cc69f8072d57529e147c86fe2530 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -260,12 +260,6 @@ else
     $(SCRIPT_DIR)/rstrip.sh
 endif
 
-ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=--enable-nls
-else
-  DISABLE_NLS:=--disable-nls
-endif
-
 ifeq ($(CONFIG_IPV6),y)
   DISABLE_IPV6:=
 else
index 627baff52835d89e369811d9ffd5a002baac0247..10de1f883ff16f683c44f6b0d18b84027d383e61 100644 (file)
@@ -29,7 +29,6 @@ define Host/Configure
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
-               $(DISABLE_NLS) \
                --without-uiout \
                --disable-tui --disable-gdbtk --without-x \
                --without-included-gettext \
index 9fb39e19320b4bcece06d3b99c3d435c1aa8def9..3744f5645117731118cdbe66f787675e10e023d0 100644 (file)
@@ -28,7 +28,6 @@ define Host/Configure
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
-               $(DISABLE_NLS) \
                --enable-threads \
                --enable-werror=no \
        );