ipq40xx: add support for EnGenius EMD1
authorYen-Ting-Shen <frank.shen@senao.com>
Fri, 1 Nov 2019 06:00:40 +0000 (14:00 +0800)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 26 Jan 2020 00:20:45 +0000 (01:20 +0100)
SOC:     IPQ4018 / QCA Dakota
CPU:     Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7
DRAM:    256 MiB
NOR:     32 MiB
ETH:     Qualcomm Atheros QCA8072 (1 port)
WLAN1:   Qualcomm Atheros QCA4018 2.4GHz 802.11bgn 2:2x2
WLAN2:   Qualcomm Atheros QCA4018 5GHz 802.11a/n/ac 2:2x2
INPUT:   RESET Button
LEDS:    White, Blue, Red, Orange

Flash instruction:

From EnGenius firmware to OpenWrt firmware:

In Firmware Upgrade page, upgrade your openwrt-ipq40xx-generic-engenius_emd1-squashfs-factory.bin directly.

From OpenWrt firmware to EnGenius firmware:

1. Setup a TFTP server on your computer and configure static IP to 192.168.99.8
   Put the EnGenius firmware in the TFTP server directory on your computer.
2. Power up EMD1. Press 4 and then press any key to enter u-boot.
3. Download EnGenius firmware
   (IPQ40xx) # tftpboot 0x84000000 openwrt-ipq40xx-emd1-nor-fw-s.img
4. Flash the firmware
   (IPQ40xx) # imgaddr=0x84000000 && source 0x84000000:script
5. Reboot
   (IPQ40xx) # reset

Signed-off-by: Yen-Ting-Shen <frank.shen@senao.com>
[removed BOARD_NAME]
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-engenius_emd1.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/files-4.19/arch/arm/boot/dts/qcom-ipq4018-emd1.dts [new file with mode: 0644]
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-4.19/901-arm-boot-add-dts-files.patch

index 065cda160d63ee4cc93fc0140f17b8263fe4b668..eada8baf6f28275627476d025fa90c90aac670e3 100644 (file)
@@ -28,6 +28,7 @@ ALLWIFIBOARDS:= \
        aruba_ap-303 \
        avm_fritzrepeater-1200 \
        dlink_dap2610 \
+       engenius_emd1 \
        ezviz_cs-w3-wd1200g-eup \
        linksys_ea8300 \
        qxwlan_e2600ac
@@ -96,6 +97,7 @@ endef
 $(eval $(call generate-ipq-wifi-package,aruba_ap-303,Aruba AP-303))
 $(eval $(call generate-ipq-wifi-package,avm_fritzrepeater-1200,AVM FRITZRepeater 1200))
 $(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
+$(eval $(call generate-ipq-wifi-package,engenius_emd1,EnGenius EMD1))
 $(eval $(call generate-ipq-wifi-package,ezviz_cs-w3-wd1200g-eup,EZVIZ CS-W3-WD1200G EUP))
 $(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
 $(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac,Qxwlan E2600AC))
diff --git a/package/firmware/ipq-wifi/board-engenius_emd1.qca4019 b/package/firmware/ipq-wifi/board-engenius_emd1.qca4019
new file mode 100644 (file)
index 0000000..3a2d775
Binary files /dev/null and b/package/firmware/ipq-wifi/board-engenius_emd1.qca4019 differ
index 9cfc43f1f9ff98d093a605631b3bdf9c6d5d45a9..4b636fc701365c9949329caa683dfea6514243ca 100755 (executable)
@@ -49,6 +49,7 @@ ipq40xx_setup_interfaces()
        avm,fritzrepeater-1200|\
        dlink,dap-2610 |\
        engenius,eap1300|\
+       engenius,emd1|\
        meraki,mr33|\
        netgear,ex6100v2|\
        netgear,ex6150v2|\
@@ -108,6 +109,10 @@ ipq40xx_setup_macs()
                lan_mac=$(mtd_get_mac_ascii bdcfg lanmac)
                label_mac=$lan_mac
                ;;
+       engenius,emd1)
+               lan_mac=$(mtd_get_mac_ascii 0:APPSBLENV ethaddr)
+               label_mac=$lan_mac
+               ;;
        engenius,ens620ext)
                wan_mac=$(mtd_get_mac_ascii u-boot-env ethaddr)
                lan_mac=$(macaddr_add "$wan_mac" 1)
index 22ac6eefc59a221bfac2fad6f9f342ec95d953f9..957bee12abe2a5a66a46b661ecb37124f114975b 100644 (file)
@@ -91,6 +91,10 @@ case "$FIRMWARE" in
                caldata_extract "ART" 0x1000 0x2f20
                ath10k_patch_mac $(mtd_get_mac_ascii bdcfg wlanmac)
                ;;
+       engenius,emd1)
+               caldata_extract "0:ART" 0x1000 0x2f20
+               ath10k_patch_mac $(mtd_get_mac_ascii 0:APPSBLENV wlanaddr)
+               ;;
        engenius,ens620ext)
                caldata_extract "ART" 0x1000 0x2f20
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii u-boot-env ethaddr) +2)
@@ -166,6 +170,10 @@ case "$FIRMWARE" in
                caldata_extract "ART" 0x5000 0x2f20
                ath10k_patch_mac $(mtd_get_mac_ascii bdcfg wlanmac_a)
                ;;
+       engenius,emd1)
+               caldata_extract "0:ART" 0x5000 0x2f20
+               ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii 0:APPSBLENV wlanaddr) +1)
+               ;;
        engenius,ens620ext)
                caldata_extract "ART" 0x5000 0x2f20
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii u-boot-env ethaddr) +3)
diff --git a/target/linux/ipq40xx/files-4.19/arch/arm/boot/dts/qcom-ipq4018-emd1.dts b/target/linux/ipq40xx/files-4.19/arch/arm/boot/dts/qcom-ipq4018-emd1.dts
new file mode 100644 (file)
index 0000000..cf4f793
--- /dev/null
@@ -0,0 +1,233 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "EnGenius EMD1";
+       compatible = "engenius,emd1";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+                       switch_lan_bmp = <0x20>;
+                       switch_wan_bmp = <0x00>;
+               };
+
+               edma@c080000 {
+                       status = "okay";
+                       qcom,num_gmac = <1>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "emd1:white:power";
+                       gpios = <&tlmm 58 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "emd1:red:wlan2g";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wlan5g {
+                       label = "emd1:blue:wlan5g";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               mesh {
+                       label = "emd1:orange:mesh";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio54", "gpio55", "gpio56", "gpio57";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition0@0 {
+                               label = "0:SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+                       partition1@40000 {
+                               label = "0:MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+                       partition2@60000 {
+                               label = "0:QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+                       partition3@c0000 {
+                               label = "0:CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+                       partition4@d0000 {
+                               label = "0:DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+                       partition5@e0000 {
+                               label = "0:APPSBLENV";
+                               reg = <0x000e0000 0x00010000>;
+                               read-only;
+                       };
+                       partition6@f0000 {
+                               label = "0:APPSBL";
+                               reg = <0x000f0000 0x00080000>;
+                               read-only;
+                       };
+                       partition7@170000 {
+                               label = "0:ART";
+                               reg = <0x00170000 0x00010000>;
+                               read-only;
+                       };
+                       partition8@180000 {
+                               label = "userconfig";
+                               reg = <0x00180000 0x00080000>;
+                               read-only;
+                       };
+                       partition9@200000 {
+                               compatible = "denx,fit";
+                               label = "firmware";
+                               reg = <0x200000 0x01e00000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&gmac0 {
+       qcom,phy_mdio_addr = <4>;
+       qcom,poll_required = <1>;
+       qcom,forced_speed = <1000>;
+       qcom,forced_duplex = <1>;
+       vlan_tag = <1 0x20>;
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&wifi0 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "EnGenius-EMD1";
+};
+
+&wifi1 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "EnGenius-EMD1";
+};
index 41a65280c3536c0c84da155d9e1dc078ef23f4b1..bbe4df9df40bea350038ecfa52b1cf381eee4142 100644 (file)
@@ -278,6 +278,19 @@ define Device/engenius_eap1300
 endef
 TARGET_DEVICES += engenius_eap1300
 
+define Device/engenius_emd1
+       $(call Device/FitImage)
+       DEVICE_VENDOR := EnGenius
+       DEVICE_MODEL := EMD1
+       DEVICE_DTS_CONFIG := config@4
+       SOC := qcom-ipq4018
+       IMAGE_SIZE := 30720k
+       IMAGES := sysupgrade.bin factory.bin
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += engenius_emd1
+
 define Device/engenius_ens620ext
        $(call Device/FitImage)
        DEVICE_VENDOR := EnGenius
index 9c9a31e4362c3847d8e9ee35e2646ad02542201e..11e775a5dcfa2c0ff620e239d4d1055888dcb7ad 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -785,11 +785,41 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -785,11 +785,42 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -20,6 +20,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4018-cs-w3-wd1200g-eup.dtb \
 +      qcom-ipq4018-ea6350v3.dtb \
 +      qcom-ipq4018-eap1300.dtb \
++      qcom-ipq4018-emd1.dtb \
 +      qcom-ipq4018-ens620ext.dtb \
 +      qcom-ipq4018-ex6100v2.dtb \
 +      qcom-ipq4018-ex6150v2.dtb \