generic: use padjffs2 in prepare_generic_squashfs
authorGabor Juhos <juhosg@openwrt.org>
Sat, 2 Jul 2011 08:37:58 +0000 (08:37 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 2 Jul 2011 08:37:58 +0000 (08:37 +0000)
SVN-Revision: 27356

include/image.mk

index 753e88f87ca72f4bc2e03aaf9772a8bc9a6f97dc..ef78a989d37d928f9fefedaad47e45c87cc95b86 100644 (file)
@@ -58,15 +58,7 @@ endef
 
 # pad to 4k, 8k, 64k, 128k and add jffs2 end-of-filesystem mark
 define prepare_generic_squashfs
-       dd if=$(1) of=$(KDIR)/tmpfile.0 bs=4k conv=sync
-       $(call add_jffs2_mark,$(KDIR)/tmpfile.0)
-       dd if=$(KDIR)/tmpfile.0 of=$(KDIR)/tmpfile.1 bs=4k conv=sync
-       $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
-       dd if=$(KDIR)/tmpfile.1 of=$(KDIR)/tmpfile.2 bs=64k conv=sync
-       $(call add_jffs2_mark,$(KDIR)/tmpfile.2)
-       dd if=$(KDIR)/tmpfile.2 of=$(1) bs=64k conv=sync
-       $(call add_jffs2_mark,$(1))
-       rm -f $(KDIR)/tmpfile.*
+       $(STAGING_DIR_HOST)/bin/padjffs2 $(1) 4 8 64 128        
 endef