toolchain/musl: remove old CONFIG_MUSL_ENABLE_DEBUG option
authorFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 23:44:44 +0000 (23:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 23:44:44 +0000 (23:44 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48387

toolchain/Config.in
toolchain/musl/Config.in [deleted file]
toolchain/musl/common.mk

index c7072fc17a583445efa5e152274505b273c9e486..1eb99e362a046f2832322a5c39acb85859db2e14 100644 (file)
@@ -236,7 +236,6 @@ endchoice
 
 source "toolchain/glibc/Config.in"
 source "toolchain/uClibc/Config.in"
-source "toolchain/musl/Config.in"
 
 comment "Debuggers"
        depends on TOOLCHAINOPTS
diff --git a/toolchain/musl/Config.in b/toolchain/musl/Config.in
deleted file mode 100644 (file)
index 05caa6a..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-# Debug version.
-
-config MUSL_ENABLE_DEBUG
-       bool "Build with debug information"
-       depends on TOOLCHAINOPTS && USE_MUSL
-       default n
index 986f372a6eb0b5d6dde243d5ecc9c31e761199a2..29beb14e1769f5bdcc37997f61001d67895e2fa4 100644 (file)
@@ -40,11 +40,6 @@ MUSL_CONFIGURE:= \
                --disable-gcc-wrapper \
                --enable-debug
 
-ifeq ($(CONFIG_MUSL_ENABLE_DEBUG),y)
-MUSL_CONFIGURE+= \
-       --enable-debug
-endif
-
 define Host/Prepare
        $(call Host/Prepare/Default)
        $(if $(strip $(QUILT)), \