ramips: disable sdhc for HC5661A
authorChuanhong Guo <gch981213@gmail.com>
Wed, 5 Dec 2018 15:54:00 +0000 (23:54 +0800)
committerMathias Kresin <dev@kresin.me>
Thu, 6 Dec 2018 11:17:25 +0000 (12:17 +0100)
Currently OpenWrt doesn't support switching MT7628 into AP mode
(which is done by writing some undocumented registers in MTK SDK)
Without doing so, enabling SD breaks 4 FE ports and the SD controller
doesn't work since SD pins aren't configured correctly.

Disable SDHC on HC5661A to recover the 4 FE ports.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
[drop the sdhci node completely]
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/dts/HC5661A.dts
target/linux/ramips/image/mt76x8.mk

index 5640154651387bb113d21961226d9986897650be..6dfac50618054b5df3e9daef9cc50ec32377fb8a 100644 (file)
        };
 };
 
-&sdhci {
-       status = "okay";
-};
-
 &spi0 {
        status = "okay";
 
index d2f402e9399c929f7d8d08b60f773882c8550a37..fe414acfb502e627891e92881c3e9b5eff2b7f03 100644 (file)
@@ -65,7 +65,6 @@ define Device/hc5661a
   DTS := HC5661A
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   DEVICE_TITLE := HiWiFi HC5661A
-  DEVICE_PACKAGES := kmod-sdhci-mt7620
 endef
 TARGET_DEVICES += hc5661a