tools/e2fsprogs: update to version 1.41.14
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 29 Dec 2010 17:38:48 +0000 (17:38 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 29 Dec 2010 17:38:48 +0000 (17:38 +0000)
SVN-Revision: 24851

tools/e2fsprogs/Makefile
tools/e2fsprogs/patches/004-big_endian_compile_fix.patch [deleted file]

index 413e965a0ecc1d48f44dce305c8fb0ceb6699441..330e10475d1713041ac484279ceb0fad37dcbd74 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.13
-PKG_MD5SUM:=7508a192c7a9471e2128424f4eafac1c
+PKG_VERSION:=1.41.14
+PKG_MD5SUM:=05f70470aea2ef7efbb0845b2b116720
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/tools/e2fsprogs/patches/004-big_endian_compile_fix.patch b/tools/e2fsprogs/patches/004-big_endian_compile_fix.patch
deleted file mode 100644 (file)
index 9c3e336..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Theodore Ts'o <tytso@mit.edu>
-Date: Fri, 17 Dec 2010 03:11:43 +0000 (-0500)
-Subject: libext2fs: Fix compile bug on big-endian architectures
-X-Git-Url: http://git.kernel.org/?p=fs%2Fext2%2Fe2fsprogs.git;a=commitdiff_plain;h=9098c986b64bb65a2b7fcd2724a400ba1f451f6b
-
-libext2fs: Fix compile bug on big-endian architectures
-
-Addresses-Sourceforge-Bug: #3138115
-
-Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
----
-
-diff --git a/lib/ext2fs/swapfs.c b/lib/ext2fs/swapfs.c
-index 6f6cec2..12427e0 100644
---- a/lib/ext2fs/swapfs.c
-+++ b/lib/ext2fs/swapfs.c
-@@ -72,7 +72,7 @@ void ext2fs_swap_super(struct ext2_super_block * sb)
-       sb->s_flags = ext2fs_swab32(sb->s_flags);
-       sb->s_kbytes_written = ext2fs_swab64(sb->s_kbytes_written);
-       sb->s_snapshot_inum = ext2fs_swab32(sb->s_snapshot_inum);
--      sb->s_snapshot_id = ext2fs_swab32(s_snapshot_id);
-+      sb->s_snapshot_id = ext2fs_swab32(sb->s_snapshot_id);
-       sb->s_snapshot_r_blocks_count =
-               ext2fs_swab64(sb->s_snapshot_r_blocks_count);
-       sb->s_snapshot_list = ext2fs_swab32(sb->s_snapshot_list);
-