firewall: don't filter IPv4 ICMP types (#10928)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 7 Feb 2012 18:35:48 +0000 (18:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 7 Feb 2012 18:35:48 +0000 (18:35 +0000)
SVN-Revision: 30363

package/firewall/Makefile
package/firewall/files/lib/fw.sh

index 746cca4882b3cfa0ac2261db5e044ac3fc8137cc..978154b3f783e3cf5662c7c399fe8f6b6c1ef20c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=44
+PKG_RELEASE:=45
 
 include $(INCLUDE_DIR)/package.mk
 
index 0814ffc315506ac2ea7a3f231a813f80ad6605fe..76e294f5683ce226304cf376dad852a16aacbaf1 100644 (file)
@@ -275,10 +275,7 @@ fw_check_icmptype4() {
                export FW_ICMP4_TYPES=$(
                        iptables -p icmp -h 2>/dev/null | \
                        sed -n -e '/^Valid ICMP Types:/ {
-                               n; :r;
-                               /router-advertisement/d;
-                               /router-solicitation/d;
-                               s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
+                               n; :r; s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
                        }' | sort -u
                )