kernel: add kernel package for the rs5c372a rtc module
authorFlorian Fainelli <f.fainelli@gmail.com>
Wed, 30 Nov 2016 01:09:58 +0000 (17:09 -0800)
committerFelix Fietkau <nbd@nbd.name>
Sun, 4 Dec 2016 10:41:51 +0000 (11:41 +0100)
This RTC is used on the Buffalo Terastation Pro II/Live devices.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/kernel/linux/modules/other.mk

index 5ba0e5e420815dc9f73e8b1d1edd9ac5cbbb14e0..e1b1e16d1dbc1a87350a48aa0260ac4e56f99d3e 100644 (file)
@@ -666,6 +666,22 @@ endef
 
 $(eval $(call KernelPackage,rtc-snvs))
 
+define KernelPackage/rtc-rs5c372a
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Ricoh R2025S/D, RS5C372A/B, RV5C386, RV5C387A
+  DEPENDS:=@RTC_SUPPORT +kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_RS5C372 \
+       CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-rs5c372.ko
+  AUTOLOAD:=$(call AutoLoad,50,rtc-rs5c372,1)
+endef
+
+define KernelPackage/rtc-rs5c372a/description
+ Kernel module for Ricoh R2025S/D, RS5C372A/B, RV5C386, RV5C387A RTC on chip module
+endef
+
+$(eval $(call KernelPackage,rtc-rs5c372a))
+
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)