kernel/modules: kmod-sched: add some common, useful actions
authorTony Ambardar <itugrok@yahoo.com>
Tue, 30 Oct 2018 12:50:51 +0000 (05:50 -0700)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 11 Feb 2019 20:18:48 +0000 (20:18 +0000)
Add act_pedit, act_csum, act_gact and act_simple modules for additional
tc action support. Module act_simple helps with debug and logging, similar
to iptables LOG target, while act_gact provides common generic actions.
Modules act_pedit and act_csum support general packet mangling, and have
been the subject of feature requests and forum discussions (e.g. DSCP),
as well as being added to the Turris OS fork of OpenWrt ~2 years ago.

Also select dependency kmod-lib-crc32c to support act_csum.

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/kernel/linux/modules/netsupport.mk

index 8e6be05916afdcf9fab0be198330aedc7922234c..96fd778176d1e4ee65012b731559be85eb866d6d 100644 (file)
@@ -770,7 +770,7 @@ $(eval $(call KernelPackage,sched-connmark))
 define KernelPackage/sched
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Extra traffic schedulers
-  DEPENDS:=+kmod-sched-core +kmod-ipt-core
+  DEPENDS:=+kmod-sched-core +kmod-ipt-core +kmod-lib-crc32c
   KCONFIG:= \
        CONFIG_NET_SCH_CODEL \
        CONFIG_NET_SCH_DSMARK \
@@ -784,7 +784,11 @@ define KernelPackage/sched
        CONFIG_NET_SCH_FQ \
        CONFIG_NET_SCH_PIE \
        CONFIG_NET_ACT_POLICE \
+       CONFIG_NET_ACT_GACT \
        CONFIG_NET_ACT_IPT \
+       CONFIG_NET_ACT_PEDIT \
+       CONFIG_NET_ACT_SIMP \
+       CONFIG_NET_ACT_CSUM \
        CONFIG_NET_EMATCH_CMP \
        CONFIG_NET_EMATCH_NBYTE \
        CONFIG_NET_EMATCH_META \