iproute2: print help in connmark
authorLuka Perkov <luka@openwrt.org>
Tue, 14 May 2013 23:49:31 +0000 (23:49 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 14 May 2013 23:49:31 +0000 (23:49 +0000)
SVN-Revision: 36637

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/200-act_connmark.patch

index 578010f76fe6d68f3e059aff717fab4fb06475c0..a875ffc76b9d5e9079a8294fee4ef51ded5052e5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=3.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
index 4a48ac3f0198c26acce337356c15e1073ee72bc8..ac6ba3379280f050b0c34b93758796fd8f39600b 100644 (file)
@@ -10,7 +10,7 @@
  TCMODULES += p_icmp.o
 --- /dev/null
 +++ b/tc/m_connmark.c
-@@ -0,0 +1,71 @@
+@@ -0,0 +1,74 @@
 +/*
 + * m_connmark.c               Connection tracking marking import
 + *
@@ -62,6 +62,9 @@
 +
 +      NEXT_ARG();
 +
++      if (matches(*argv, "help") == 0)
++              usage();
++
 +      *argc_p = argc;
 +      *argv_p = argv;
 +      return 0;