ramips: add suport for ZBT APE522II
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>
Thu, 23 Jun 2016 08:58:08 +0000 (10:58 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 22 Jun 2016 17:32:06 +0000 (19:32 +0200)
The ZBT APE522II is a dual-radio outdoor CPE based on the MT7620a SoC. It has
64 MB RAM, 8 MB flash, 2 Fast Ethernet ports via internal switch (one with
802.3af 48V PoE support), a 802.11b/g/n SoC 2.4 GHz radio and an 802.11a/n/ac
MT7612E-based 5 GHz radio.

Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-APE522II.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 3aac1e45f5ddeb25b0cd8fafc538efcf9e57f5c7..460253c9ff29ee55f1da4073555eab63e7affad6 100755 (executable)
@@ -296,6 +296,11 @@ y1s)
        set_usb_led "$board:blue:usb"
        set_wifi_led "$board:blue:wifi"
        ;;
+zbt-ape522ii)
+       ucidef_set_led_netdev "wlan2g4" "wlan1-link" "$board:green:wlan2g4" "wlan1"
+       ucidef_set_led_netdev "sys1" "wlan1" "$board:green:sys1" "wlan1" "tx rx"
+       ucidef_set_led_netdev "sys2" "wlan0" "$board:green:sys2" "wlan0" "tx rx"
+       ;;
 zbt-wa05)
        ucidef_set_led_default "power" "power" "$board:blue:power" "1"
        set_wifi_led "$board:blue:air"
index be1912a1b013540a9c9a558e7103a5f60143d976..dbb5fb43e01a289832ac646f85f4276f6dea03f8 100755 (executable)
@@ -224,6 +224,7 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "0:wan" "6@eth0"
                ;;
+       zbt-ape522ii|\
        zbt-we826|\
        zbt-wr8305rt)
                ucidef_add_switch "switch0" \
index bd4f33d3d52827b6c6dcabb5e56b503405fd1b30..10139d7fc6202e65a16575f09f13774dd2c65c62 100755 (executable)
@@ -523,6 +523,9 @@ ramips_board_detect() {
        *"Y1S")
                name="y1s"
                ;;
+       *"ZBT-APE522II")
+               name="zbt-ape522ii"
+               ;;
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
index 0b3d8c74066a54ad8f3a448f89463218213efaca..e3bea004fa9f4684c2d256bbdea072a2d783ddbc 100755 (executable)
@@ -155,6 +155,7 @@ platform_check_image() {
        x8|\
        y1|\
        y1s|\
+       zbt-ape522ii|\
        zbt-wa05|\
        zbt-we826|\
        zbt-wg2626|\
diff --git a/target/linux/ramips/dts/ZBT-APE522II.dts b/target/linux/ramips/dts/ZBT-APE522II.dts
new file mode 100644 (file)
index 0000000..eff27c2
--- /dev/null
@@ -0,0 +1,143 @@
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+/ {
+       compatible = "zbtlink,zbt-ape522ii", "ralink,mt7620a-soc";
+       model = "ZBT-APE522II";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               sys1 {
+                       label = "zbt-ape522ii:green:sys1";
+                       gpios = <&gpio0 11 1>;
+               };
+
+               sys2 {
+                       label = "zbt-ape522ii:green:sys2";
+                       gpios = <&gpio0 12 1>;
+               };
+
+               sys3 {
+                       label = "zbt-ape522ii:green:sys3";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               sys4 {
+                       label = "zbt-ape522ii:green:sys4";
+                       gpios = <&gpio0 14 1>;
+               };
+
+               wlan2g4 {
+                       label = "zbt-ape522ii:green:wlan2g4";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 2 0>;
+                       linux,code = <0x198>;
+               };
+       };
+};
+
+&gpio0 {
+       status = "okay";
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio2 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               linux,modalias = "m25p80", "w25q64";
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0xf80000>;
+               };
+       };
+};
+
+&ethernet {
+       pinctrl-names = "default";
+       pinctrl-0 = <&ephy_pins>;
+       mtd-mac-address = <&factory 0x4>;
+       mediatek,portmap = "wllll";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pcie {
+       status = "okay";
+
+       pcie-bridge {
+               mt76@0,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x8000>;
+                       mediatek,2ghz = <0>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wled", "i2c", "uartf", "wdt";
+                       ralink,function = "gpio";
+               };
+
+               pa {
+                       ralink,group = "pa";
+                       ralink,function = "pa";
+               };
+       };
+};
index 33f94a48e9245e84f0a18b40eff79d3485703ff6..b1afb82c0034664c00ee916779a0a0917dc915e4 100644 (file)
@@ -376,6 +376,14 @@ define Device/youku-yk1
 endef
 TARGET_DEVICES += youku-yk1
 
+define Device/zbt-ape522ii
+  DTS := ZBT-APE522II
+  IMAGE_SIZE := $(ralink_default_fw_size_8M)
+  DEVICE_TITLE := Zbtlink ZBT-APE522II
+  DEVICE_PACKAGES := kmod-mt76
+endef
+TARGET_DEVICES += zbt-ape522ii
+
 define Device/zbt-wa05
   DTS := ZBT-WA05
   IMAGE_SIZE := $(ralink_default_fw_size_8M)