brcm47xx: image: build firmware for Asus WL-500g Deluxe
authorRafał Miłecki <rafal@milecki.pl>
Wed, 27 Dec 2017 07:55:28 +0000 (08:55 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 29 Dec 2017 22:18:19 +0000 (23:18 +0100)
It's a device based on BCM5365P (0x5365 package 0x00). This SoC has
USB 1.1 controller but device has two USB 2.0 parts. They are handled by
PCI-based controllers: 1106:3038 UHCI and 1106:3104 EHCI.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/brcm47xx/image/Makefile

index 284e1f7c05745b8a1162cdc0c420f9030acb86cc..47f031b8b4e16eed86ed884d332d6d1df845f8b1 100644 (file)
@@ -282,6 +282,14 @@ define Device/asus-wl-330ge
 endef
 TARGET_DEVICES += asus-wl-330ge
 
+define Device/asus-wl-500gd
+  DEVICE_TITLE := Asus WL-500g Deluxe
+  DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
+  $(Device/asus)
+  PRODUCTID := "WL500gx     "
+endef
+TARGET_DEVICES += asus-wl-500gd
+
 define Device/asus-wl-500gp-v1
   DEVICE_TITLE := Asus WL-500gP v1
   DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)