imagebuilder: remove existing debug kernel image
authorFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 18:22:09 +0000 (19:22 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 18:46:45 +0000 (19:46 +0100)
Reduces tarball size and improves build time

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/imagebuilder/Makefile

index 13eed7e108ca27fd40c05b6e1de144ac53b5e9b0..d891aab18cccb27e42a4800b6e021f761292fd13 100644 (file)
@@ -67,6 +67,7 @@ endif
        -cp $(KERNEL_BUILD_DIR)/* $(IB_KDIR)/ # don't copy subdirectories here
        -cp $(LINUX_DIR)/.config $(IB_LDIR)/
        rm -f $(IB_KDIR)/root.*
+       rm -f $(IB_KDIR)/vmlinux.debug
        if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
                $(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \
                $(INSTALL_BIN) $(LINUX_DIR)/scripts/dtc/dtc $(IB_LDIR)/scripts/dtc/dtc; \