kernel/modules: fix kmod-fs-btrfs deps / zlib_deflate / makefile
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Tue, 12 Apr 2011 23:18:30 +0000 (23:18 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Tue, 12 Apr 2011 23:18:30 +0000 (23:18 +0000)
btrfs needs zlib_deflate, which was built but not included

Signed-off-by: Bastian Bittorf <bittorf@bluebottle.com>
SVN-Revision: 26632

package/kernel/modules/fs.mk

index 846bc8233f3cd5963c21746e9135985d0949c34f..c2ae55194808534687359537c056a08e6b28c9bd 100644 (file)
@@ -28,10 +28,12 @@ define KernelPackage/fs-btrfs
   DEPENDS:=+kmod-libcrc32c
   KCONFIG:=\
        CONFIG_BTRFS_FS \
-       CONFIG_BTRFS_FS_POSIX_ACL=n
+       CONFIG_BTRFS_FS_POSIX_ACL=n \
+       CONFIG_ZLIB_DEFLATE
   FILES:=\
-       $(LINUX_DIR)/fs/btrfs/btrfs.ko
-  AUTOLOAD:=$(call AutoLoad,30,btrfs,1)
+       $(LINUX_DIR)/fs/btrfs/btrfs.ko \
+       $(LINUX_DIR)/lib/zlib_deflate/zlib_deflate.ko
+  AUTOLOAD:=$(call AutoLoad,30,zlib_deflate btrfs,1)
 endef
 
 define KernelPackage/fs-btrfs/description