lantiq: rename gphy firmware
authorMathias Kresin <dev@kresin.me>
Sun, 31 Dec 2017 10:48:15 +0000 (11:48 +0100)
committerMathias Kresin <dev@kresin.me>
Tue, 20 Feb 2018 18:25:17 +0000 (19:25 +0100)
Rename the gphy firmware to match the name requested by kernel 4.14 and
update the devicetree source files to use the new name.

Update the u-boot lantiq Makefile to be compatible with the new names as
well.

Signed-off-by: Mathias Kresin <dev@kresin.me>
24 files changed:
package/boot/uboot-lantiq/Makefile
target/linux/lantiq/dts/ARV7519RW22.dts
target/linux/lantiq/dts/ASL56026.dts
target/linux/lantiq/dts/BTHOMEHUBV5A.dts
target/linux/lantiq/dts/DM200.dts
target/linux/lantiq/dts/EASY80920.dtsi
target/linux/lantiq/dts/FRITZ3370.dts
target/linux/lantiq/dts/FRITZ7360SL.dts
target/linux/lantiq/dts/P2812HNUFX.dtsi
target/linux/lantiq/dts/TDW89X0.dtsi
target/linux/lantiq/dts/VG3503J.dts
target/linux/lantiq/dts/VGV7510KW22.dtsi
target/linux/lantiq/dts/VGV7519.dtsi
target/linux/lantiq/dts/VR200v.dts
target/linux/lantiq/dts/WBMR300.dts
target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a1x.bin [deleted file]
target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a2x.bin [deleted file]
target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a1x.bin [deleted file]
target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a2x.bin [deleted file]
target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a14.bin [new file with mode: 0644]
target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a22.bin [new file with mode: 0644]
target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a14.bin [new file with mode: 0644]
target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a22.bin [new file with mode: 0644]
target/linux/lantiq/patches-4.9/0024-NET-lantiq-adds-PHY11G-firmware-blobs.patch

index 5493737d3fe3a264d6e857c1e7127b674b56f80e..55038fdf657fd746b9c66bf4bd501e6510bb6f74 100644 (file)
@@ -353,17 +353,17 @@ UBOOT_TARGETS:= \
 
 define CompressVR9Firmware
        $(STAGING_DIR_HOST)/bin/lzma e \
-               $(FIRMWARE_LANTIQ_SOURCE)/vr9_phy$(1)_a$(2)x.bin \
+               $(FIRMWARE_LANTIQ_SOURCE)/xrx200_phy$(1)_a$(2)$(3).bin \
                $(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/fw_phy$(1)_a$(2)x.blob
 endef
 
 define Build/Prepare
        $(call Build/Prepare/Default)
        mkdir -p $(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/
-       $(call CompressVR9Firmware,11g,1)
-       $(call CompressVR9Firmware,11g,2)
-       $(call CompressVR9Firmware,22f,1)
-       $(call CompressVR9Firmware,22f,2)
+       $(call CompressVR9Firmware,11g,1,4)
+       $(call CompressVR9Firmware,11g,2,2)
+       $(call CompressVR9Firmware,22f,1,4)
+       $(call CompressVR9Firmware,22f,2,2)
 endef
 
 UBOOT_MAKE_FLAGS :=
index 9e2ae9d6f2d9ca5cf4d957003c2b7bb197d70451..0bdc150a1e7cd16a97d07f7c067fac5d6288d0cc 100644 (file)
@@ -99,8 +99,8 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy22f_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy22f_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy22f_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy22f_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index 293a3e27de16cec5a0bda9417b83f31e0d1c7c9b..2037f40f039248377b9b919886e1097d45a5c3f4 100644 (file)
@@ -77,8 +77,8 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy22f_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy22f_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy22f_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy22f_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index 4bdeddcafa7e417b5256286bde502bddf6a14185..2f75074696531595f9fc30f21047e269be4ee356 100644 (file)
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy11g_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy11g_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy11g_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy11g_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index eef4084915e946a8ef1c7d5250da30cf3c273d09..3c8a2a1fa96f44451927c239603e939f716377b8 100644 (file)
@@ -56,7 +56,7 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy22f_a2x.bin";
+               firmware = "lantiq/xrx200_phy22f_a22.bin";
                phys = [ 01 ];
        };
 
index 3565842f247218bec7c443c305c4fb5a4b686a74..b19b9713f6c0fa3199e32e7e112b2f12d8167306 100644 (file)
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy11g_a1x.bin";
-               firmware2 = "lantiq/vr9_phy11g_a2x.bin";
+               firmware1 = "lantiq/xrx200_phy11g_a14.bin";
+               firmware2 = "lantiq/xrx200_phy11g_a22.bin";
                phys = [ 00 01 ];
        };
 
index 76f7f877bc7d8bae4419b854ddbf019fde80a984..ef3655de61cba323c1597754a243571d33b55720 100644 (file)
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy11g_a1x.bin";
+               firmware = "lantiq/xrx200_phy11g_a14.bin";
                phys = [ 00 01 ];
        };
 
index cf82451400f963cdb422bd483e060542855d4c82..b1648711014257102443900eca7ed78f7350586e 100644 (file)
@@ -98,7 +98,7 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy11g_a2x.bin";
+               firmware = "lantiq/xrx200_phy11g_a22.bin";
                phys = [ 00 01 ];
        };
 
index 9429d5caf3f8aafb455aec5e964efae83337866c..ec3bd1033dd1207d3d89451ada7396ad0eca0f44 100644 (file)
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy11g_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy11g_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy11g_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy11g_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index 79bcfc103b600150f74785768ee0c2f1b0ad5f8b..a629d92e4f2a76fcab90cb15c6cef965ab77204f 100644 (file)
@@ -82,7 +82,7 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy11g_a2x.bin";
+               firmware = "lantiq/xrx200_phy11g_a22.bin";
                phys = [ 00 01 ];
        };
 
index cb0d5ddecd2f1220a10593b283e77c33a3e962d3..8a73de9a267fd870e95c57985159650e51f447f1 100644 (file)
@@ -81,8 +81,8 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy11g_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy11g_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy11g_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy11g_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index 2d8e528f4e06f940f9fde58d2f1b4eb613d2729f..fb4486aca24d5342e0ec5122ebe3cf0ad1decb3c 100644 (file)
@@ -93,8 +93,8 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy22f_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy22f_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy22f_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy22f_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index edff93cf4799989ed6cd6412bcad3fce680af2ca..e807b527151f4c5928b61c4b50377de53da07dc4 100644 (file)
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware1 = "lantiq/vr9_phy11g_a1x.bin";        /*VR9 1.1*/
-               firmware2 = "lantiq/vr9_phy11g_a2x.bin";        /*VR9 1.2*/
+               firmware1 = "lantiq/xrx200_phy11g_a14.bin";     /*VR9 1.1*/
+               firmware2 = "lantiq/xrx200_phy11g_a22.bin";     /*VR9 1.2*/
                phys = [ 00 01 ];
        };
 
index b063d758c3a63ae7f4451735bda76f57f00e1b55..6eccc5bdd96f2b00e4462bd1d189b3a9e15337f4 100644 (file)
@@ -88,7 +88,7 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy11g_a2x.bin";
+               firmware = "lantiq/xrx200_phy11g_a22.bin";
                phys = [ 00 01 ];
        };
 
index de2be582f575b7eb818e50cec72d3299a8734074..2ecfe4bc92f574ff42ef35c9e55f88658f61f378 100644 (file)
@@ -76,7 +76,7 @@
 
        gphy-xrx200 {
                compatible = "lantiq,phy-xrx200";
-               firmware = "lantiq/vr9_phy22f_a2x.bin";
+               firmware = "lantiq/xrx200_phy22f_a22.bin";
                phys = [ 00 01 ];
        };
 
diff --git a/target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a1x.bin b/target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a1x.bin
deleted file mode 100644 (file)
index cdf3d30..0000000
Binary files a/target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a1x.bin and /dev/null differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a2x.bin b/target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a2x.bin
deleted file mode 100644 (file)
index 44fc39e..0000000
Binary files a/target/linux/lantiq/files/firmware/lantiq/vr9_phy11g_a2x.bin and /dev/null differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a1x.bin b/target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a1x.bin
deleted file mode 100644 (file)
index 02b88a0..0000000
Binary files a/target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a1x.bin and /dev/null differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a2x.bin b/target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a2x.bin
deleted file mode 100644 (file)
index 1fed6ad..0000000
Binary files a/target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a2x.bin and /dev/null differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a14.bin b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a14.bin
new file mode 100644 (file)
index 0000000..cdf3d30
Binary files /dev/null and b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a14.bin differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a22.bin b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a22.bin
new file mode 100644 (file)
index 0000000..44fc39e
Binary files /dev/null and b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy11g_a22.bin differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a14.bin b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a14.bin
new file mode 100644 (file)
index 0000000..02b88a0
Binary files /dev/null and b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a14.bin differ
diff --git a/target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a22.bin b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a22.bin
new file mode 100644 (file)
index 0000000..1fed6ad
Binary files /dev/null and b/target/linux/lantiq/files/firmware/lantiq/xrx200_phy22f_a22.bin differ
index b69b2a900ffd882a5f8baac22cb0c75aa78407a0..e62ff2f69825df624e213ea0b09e583261778b25 100644 (file)
@@ -18,10 +18,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  fw-shipped-$(CONFIG_USB_SERIAL_XIRCOM) += keyspan_pda/xircom_pgs.fw
  fw-shipped-$(CONFIG_USB_VICAM) += vicam/firmware.fw
  fw-shipped-$(CONFIG_VIDEO_CPIA2) += cpia2/stv0672_vp4.bin
-+fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/vr9_phy11g_a1x.bin
-+fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/vr9_phy11g_a2x.bin
-+fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/vr9_phy22f_a1x.bin
-+fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/vr9_phy22f_a2x.bin
++fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/xrx200_phy11g_a14.bin
++fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/xrx200_phy11g_a22.bin
++fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/xrx200_phy22f_a14.bin
++fw-shipped-$(CONFIG_LANTIQ_XRX200) += lantiq/xrx200_phy22f_a22.bin
  fw-shipped-$(CONFIG_YAM) += yam/1200.bin yam/9600.bin
  
  fw-shipped-all := $(fw-shipped-y) $(fw-shipped-m) $(fw-shipped-)
@@ -356,9 +356,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +#
 +
 +# GPHY core on Lantiq XWAY VR9 v1.1
-+lantiq/vr9_phy11g_a1x.bin
-+lantiq/vr9_phy22f_a1x.bin
++lantiq/xrx200_phy11g_a14.bin
++lantiq/xrx200_phy22f_a14.bin
 +
 +# GPHY core on Lantiq XWAY VR9 v1.2
-+lantiq/vr9_phy11g_a2x.bin
-+lantiq/vr9_phy22f_a2x.bin
++lantiq/xrx200_phy11g_a22.bin
++lantiq/xrx200_phy22f_a22.bin