hostapd: fix stray "out of range" shell errors in hostapd.sh
authorJo-Philipp Wich <jo@mein.io>
Mon, 23 Jan 2017 13:52:27 +0000 (14:52 +0100)
committerJo-Philipp Wich <jo@mein.io>
Mon, 23 Jan 2017 13:55:46 +0000 (14:55 +0100)
The hostapd_append_wpa_key_mgmt() procedure uses the possibly uninitialized
$ieee80211r and $ieee80211w variables in a numerical comparisation, leading
to stray "netifd: radio0 (0000): sh: out of range" errors in logread when
WPA-PSK security is enabled.

Ensure that those variables are substituted with a default value in order to
avoid emitting this (harmless) shell error.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/netifd.sh

index 96b652f67165e0be0419e0ef140e5580e086f110..50c162efa5874474aa18e0063369615683921904 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index fb23e52e679f076f575ff45e3a0df32de6c27003..937825de11e781dfeed06553ae3dab952f8a112c 100644 (file)
@@ -40,8 +40,8 @@ hostapd_append_wpa_key_mgmt() {
        local auth_type="$(echo $auth_type | tr 'a-z' 'A-Z')"
 
        append wpa_key_mgmt "WPA-$auth_type"
-       [ "$ieee80211r" -gt 0 ] && append wpa_key_mgmt "FT-${auth_type}"
-       [ "$ieee80211w" -gt 0 ] && append wpa_key_mgmt "WPA-${auth_type}-SHA256"
+       [ "${ieee80211r:-0}" -gt 0 ] && append wpa_key_mgmt "FT-${auth_type}"
+       [ "${ieee80211w:-0}" -gt 0 ] && append wpa_key_mgmt "WPA-${auth_type}-SHA256"
 }
 
 hostapd_add_log_config() {