mt76: update to the latest version, improves mt7603 support
authorFelix Fietkau <nbd@nbd.name>
Wed, 15 Mar 2017 19:56:06 +0000 (20:56 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 15 Mar 2017 19:56:37 +0000 (20:56 +0100)
03e44dc mt76x2: remove unnecessary headroom check
cc70498 mt76x2: clarify queue selection field
b056a78 dma: fix endian issue in mt76_dma_get_buf
f020a60 mt7603: support loading the entire EEPROM from OTP
29b08d3 mt7603: fix endian issue in mt7603_mcu_set_timing
dce8aac mt7603: fix endian issue in mt7603_mac_fill_rx
f22273b mt7603: init WTBL entry before setting capabilities
da8e796 mt7603: check wtbl busy status and stop/start tx queues when clearing sta entry
e54add5 mt7603: move napi/tasklet enable/disable outside of the locked section
59ce2b4 mt7603: set tx vif own MAC index (needed for beacons)
93ce124 mt7603: enable beacons for other virtual interfaces
c91e660 mt7603: set secondary beacon time offsets

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index 7885825aaa5ecd42a22b086b7c4d32e88b570d20..c4804e6bdb39c08bdbf5b2ec02eb7bbc3bfa0aed 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2017-02-03
-PKG_SOURCE_VERSION:=a5eaeb27d6a80c012ffc8b5bb5549983e446b4ef
-PKG_MIRROR_HASH:=c526586aba890c5645320145219bd5932e39cfc2ea540d7674c9a58ab9a4a36a
+PKG_SOURCE_DATE:=2017-03-15
+PKG_SOURCE_VERSION:=c91e66098541cb96a4cc47a9598d78623269686c
+PKG_MIRROR_HASH:=7fea52630fb682cdf8fbffaac1ec8d20d0c269b088b0ee697d16bbe6dba5b797
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1