standardize Makefile, change section from base to utils, remove dup description
authorNicolas Thill <nico@openwrt.org>
Sat, 23 Sep 2006 14:00:36 +0000 (14:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 23 Sep 2006 14:00:36 +0000 (14:00 +0000)
SVN-Revision: 4830

openwrt/package/pcmcia-cs/Makefile

index fcdf71cd76ac29fe9cf0dac87a5b1813a1447488..5cd77c833a0887eacc5313b05eabafa710070c45 100644 (file)
@@ -23,11 +23,11 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcmcia-cs
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcmcia-cs
-SECTION:=base
-DEPENDS:=@PCMCIA_SUPPORT
-TITLE:=PCMCIA/Cardbus management utilities
-DESCRIPTION:=PCMCIA/Cardbus management utilities
-URL:=http://pcmcia-cs.sourceforge.net/
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_4&&PCMCIA_SUPPORT
+  TITLE:=PCMCIA/Cardbus management utilities
+  URL:=http://pcmcia-cs.sourceforge.net/
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
@@ -45,18 +45,22 @@ define Build/Configure
                        --nopnp \
                        --notrust \
                        --nox11 \
                        --nopnp \
                        --notrust \
                        --nox11 \
-                       --sysv --rcdir="/etc" \
+                       --rcdir="/etc" \
+                       --sysv \
        )
 endef
 
 define Build/Compile
        )
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default,CFLAGS="$(TARGET_CFLAGS)" all install)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all install \
+       )
 endef
 
 define Package/pcmcia-cs/install
 endef
 
 define Package/pcmcia-cs/install
-       install -m0755 -d $(1)/etc
+       install -d -m0755 $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
-       install -m0755 -d $(1)/usr/sbin
+       install -d -m0755 $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef