ath79: Add support for TP-Link Archer C60 v1
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 5 May 2019 16:36:43 +0000 (18:36 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 17 Jul 2019 22:06:55 +0000 (00:06 +0200)
TP-Link Archer C60v1 is a dual-band AC1350 router,
based on Qualcomm/Atheros QCA9561+QCA9886.

Specification:

- 775/650/258 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR2)
- 8 MB of FLASH (SPI NOR)
- 3T3R 2.4 GHz
- 2T2R 5 GHz
- 5x 10/100 Mbps Ethernet
- 7x LED, 2x button
- UART header on PCB

Flash instruction (WebUI):
Download *-factory.bin image and upload it via the firmwary upgrade
function of the stock firmware WebUI.

Flash instruction (TFTP):
1. Set PC to fixed ip address 192.168.0.66
2. Download *-factory.bin image and rename it to tp_recovery.bin
3. Start a tftp server with the file tp_recovery.bin in its root directory
4. Turn off the router
5. Press and hold Reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time
the firmware should be transferred from the tftp server
8. Wait ~30 second to complete recovery.

Flash instruction under U-Boot, using UART:
1. tftp 0x81000000 ...-sysupgrade.bin
2. erase 0x9f020000 +$filesize
3. cp.b $fileaddr 0x9f020000 $filesize
4. reset

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9561_tplink_archer-c60-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9561_tplink_archer-c6x.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

index 0cb03db4bee93a4ba66e5dd566e3ea2a418050b1..981ff24e939434daa1a6b590e771b317e6d97993 100755 (executable)
@@ -140,7 +140,8 @@ tplink,tl-wr842n-v3)
        ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
        ;;
 tplink,archer-c58-v1|\
-tplink,archer-c59-v1)
+tplink,archer-c59-v1|\
+tplink,archer-c60-v1)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
        ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
        ;;
index 1d4cec025adbe7cf468e08376e8b3a9ca43368cd..de77203152a5a277cef35c0bebd5c6cf42e87075 100755 (executable)
@@ -217,6 +217,11 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
+       tplink,archer-c60-v1)
+               ucidef_set_interface_wan "eth1"
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "1:lan" "2:lan" "3:lan" "4:lan"
+               ;;
        tplink,archer-d50-v1)
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan:3" "3:lan:2" "4:lan:1" "1:wan"
index bdc0faffc8db80b87ee6ae800d70d5a995d4c3ed..7fa85e90488af8f18a264fc40faa732cca1eb63c 100644 (file)
@@ -208,6 +208,7 @@ case "$FIRMWARE" in
                ;;
        tplink,archer-c58-v1|\
        tplink,archer-c59-v1|\
+       tplink,archer-c60-v1|\
        tplink,archer-c6-v2)
                ath10kcal_extract "art" 20480 12064
                ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary mac 8) -1)
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c60-v1.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c60-v1.dts
new file mode 100644 (file)
index 0000000..85e456b
--- /dev/null
@@ -0,0 +1,56 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9561_tplink_archer-c6x.dtsi"
+
+/ {
+       compatible = "tplink,archer-c60-v1", "qca,qca9561";
+       model = "TP-Link Archer C60 v1";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x010000>;
+                               read-only;
+                       };
+
+                       mac: partition@10000 {
+                               label = "mac";
+                               reg = <0x010000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x020000 0x7c0000>;
+                       };
+
+                       partition@7e0000 {
+                               label = "tplink";
+                               reg = <0x7e0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c6x.dtsi b/target/linux/ath79/dts/qca9561_tplink_archer-c6x.dtsi
new file mode 100644 (file)
index 0000000..3c974e0
--- /dev/null
@@ -0,0 +1,110 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &power;
+               led-running = &power;
+               led-upgrade = &power;
+               label-mac-device = &eth0;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wifi_button {
+                       label = "WiFi button";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               reset_button {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power: power {
+                       label = "tp-link:green:power";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wlan2g {
+                       label = "tp-link:green:wlan2g";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wlan5g {
+                       label = "tp-link:green:wlan5g";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wan_green {
+                       label = "tp-link:green:wan";
+                       gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_amber {
+                       label = "tp-link:amber:wan";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+
+               wps {
+                       label = "tp-link:green:wps";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-mode = "mii";
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&mac 0x8>;
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&mac 0x8>;
+       mtd-mac-address-increment = <1>;
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&mac 0x8>;
+};
index 312ce78f226d3da0c2056e76269247eea8feafc3..51784650564f08cdde8e16209a45f7e2631cf1ce 100644 (file)
@@ -60,6 +60,18 @@ define Device/tplink_archer-c59-v1
 endef
 TARGET_DEVICES += tplink_archer-c59-v1
 
+define Device/tplink_archer-c60-v1
+  $(Device/tplink-safeloader-uimage)
+  ATH_SOC := qca9561
+  IMAGE_SIZE := 7936k
+  DEVICE_MODEL := Archer C60
+  DEVICE_VARIANT := v1
+  TPLINK_BOARD_ID := ARCHER-C60-V1
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  SUPPORTED_DEVICES += archer-c60-v1
+endef
+TARGET_DEVICES += tplink_archer-c60-v1
+
 define Device/tplink_archer-c6-v2
   $(Device/tplink-safeloader-uimage)
   ATH_SOC := qca9563