ath79: add support for Ubiquiti Picostation M (XM)
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 17 Feb 2020 23:08:18 +0000 (00:08 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 19 Feb 2020 22:20:09 +0000 (23:20 +0100)
This adds support for the Ubiquiti Picostation M (XM), which has the
same board/LEDs as the Bullet M XM, but different case and antennas.

Specifications:
- AR7241 SoC @ 400 MHz
- 32 MB RAM
- 8 MB SPI flash
- 1x 10/100 Mbps Ethernet, 24 Vdc PoE-in
- External antenna: 5 dBi (USA), 2 dBi (EU)
- POWER/LAN green LEDs
- 4x RSSI LEDs (red, orange, green, green)
- UART (115200 8N1) on PCB

Flashing via WebUI:
  Upload the factory image via the stock firmware web UI.

  Attention: airOS firmware versions >= 5.6 have a new bootloader with
  an incompatible partition table!

  Please downgrade to <= 5.5 _before_ flashing OpenWrt!
  Refer to the device's Wiki page for further information.

Flashing via TFTP:
  Same procedure as other NanoStation M boards.

- Use a pointy tool (e.g., pen cap, paper clip) and keep the reset
  button on the device or on the PoE supply pressed
- Power on the device via PoE (keep reset button pressed)
- Keep pressing until LEDs flash alternatively LED1+LED3 =>
  LED2+LED4 => LED1+LED3, etc.
- Release reset button
- The device starts a TFTP server at 192.168.1.20
- Set a static IP on the computer (e.g., 192.168.1.21/24)
- Upload via tftp the factory image:
  $ tftp 192.168.1.20
  tftp> bin
  tftp> trace
  tftp> put openwrt-ath79-generic-xxxxx-ubnt_picostation-m-squashfs-factory.bin

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts b/target/linux/ath79/dts/ar7241_ubnt_picostation-m.dts
new file mode 100644 (file)
index 0000000..e2376a1
--- /dev/null
@@ -0,0 +1,13 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar7241_ubnt_xm_outdoor.dtsi"
+
+/ {
+       compatible = "ubnt,picostation-m", "ubnt,xm", "qca,ar7241";
+       model = "Ubiquiti Picostation M";
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+};
index 3567df662b992bd34812b03aabd6e22e972a33e9..6668e15a74dd4167ed6ee1a1e65400a93eebd1e8 100755 (executable)
@@ -248,6 +248,7 @@ ubnt,nanostation-loco-m|\
 ubnt,nanostation-loco-m-xw|\
 ubnt,nanostation-m|\
 ubnt,nanostation-m-xw|\
+ubnt,picostation-m|\
 ubnt,rocket-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:red:link1" "wlan0" "1" "100"
index 993632562f8c45331152116dbd463628761a4da3..4891affe177c6d9658abef30dff26ab7893a00b0 100755 (executable)
@@ -49,6 +49,7 @@ ath79_setup_interfaces()
        ubnt,nanostation-ac-loco|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-loco-m-xw|\
+       ubnt,picostation-m|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
        ubnt,unifiac-lr|\
index ea42478c610bd880b410137f5e67ce6c55dbee45..96f9d5c0d2a2011a1ed05302b203a540ffe6f51f 100644 (file)
@@ -92,6 +92,7 @@ case "$FIRMWARE" in
        ubnt,bullet-m|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
+       ubnt,picostation-m|\
        ubnt,rocket-m)
                caldata_extract "art" 0x1000 0x1000
                ;;
index c0b612123801bba9ac02f40a741e3f1c8c303eec..a4aff09feca528a7721af35500905452000097f5 100644 (file)
@@ -211,6 +211,14 @@ define Device/ubnt_nanostation-m-xw
 endef
 TARGET_DEVICES += ubnt_nanostation-m-xw
 
+define Device/ubnt_picostation-m
+  $(Device/ubnt-xm)
+  DEVICE_MODEL := Picostation M
+  DEVICE_PACKAGES += rssileds
+  SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_picostation-m
+
 define Device/ubnt_rocket-m
   $(Device/ubnt-xm)
   DEVICE_MODEL := Rocket-M