autotools.mk: add a gettext-version PKG_FIXUP (#11236)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 10 Oct 2012 17:53:51 +0000 (17:53 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 10 Oct 2012 17:53:51 +0000 (17:53 +0000)
This fixup aligns the required gettext version in shipped macros to the one
available in $(STAGING_DIR_HOST).

SVN-Revision: 33708

include/autotools.mk

index 8796598569a748c4d61ec20d9476247929f562ed..7ebeff6c76e360ad94b23b81c2c25ef0fc140f8c 100644 (file)
@@ -83,6 +83,15 @@ define patch_libtool_target
     $(PKG_BUILD_DIR)))
 endef
 
+define gettext_version_target
+  cd $(PKG_BUILD_DIR) && \
+  GETTEXT_VERSION=$(shell $(STAGING_DIR_HOST)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.* //p') && \
+  $(STAGING_DIR_HOST)/bin/sed \
+  -i $(PKG_BUILD_DIR)/configure.ac \
+  -e "s/AM_GNU_GETTEXT_VERSION(\[.*\])/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+  $(STAGING_DIR_HOST)/bin/autopoint --force
+endef
+
 ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += patch_libtool_target
 endif
@@ -107,6 +116,10 @@ ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
   endif
 endif
 
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += gettext_version_target
+endif
+
 
 HOST_FIXUP?=$(PKG_FIXUP)
 HOST_LIBTOOL_PATHS?=$(if $(PKG_LIBTOOL_PATHS),$(PKG_LIBTOOL_PATHS),.)