target/{sdk,imagebuild}: Fix for symlink-tree
authorDaniel Dickinson <lede@cshore.thecshore.com>
Thu, 29 Sep 2016 08:14:17 +0000 (04:14 -0400)
committerJohn Crispin <john@phrozen.org>
Thu, 29 Sep 2016 22:39:25 +0000 (00:39 +0200)
With symlink tree some directories are just symlinked which
means IB and SDK end up with a symlink instead of an actual
directory; this fixes the missing files by dereferencesing
the directories instead of copying the symlinks.

Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
target/imagebuilder/Makefile
target/sdk/Makefile

index 4b61963b0a34428e937a61c64b65792606afaa50..b809193db3b358c5a5e592851d17d882aae46426 100644 (file)
@@ -26,7 +26,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        mkdir -p $(IB_KDIR) $(IB_LDIR) $(PKG_BUILD_DIR)/staging_dir/host/lib \
                $(PKG_BUILD_DIR)/target $(PKG_BUILD_DIR)/scripts $(IB_DTSDIR)
        -cp $(TOPDIR)/.config $(PKG_BUILD_DIR)/.config
-       $(CP) \
+       $(CP) -L \
                $(INCLUDE_DIR) $(SCRIPT_DIR) \
                $(TOPDIR)/rules.mk \
                ./files/Makefile \
index 4607535292c89d0f04ba766137abc662f05c4053..77695ee28569047f8053ed76342f4f9fbd1fa7fb 100644 (file)
@@ -67,7 +67,7 @@ all: compile
 
 $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
-       $(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
+       $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
        $(TAR) -cf - -C $(TOPDIR) \
                `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
                `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \