IB: fix generating .profile.mk for profiles without metadata
authorDaniel Golle <daniel@makrotopia.org>
Wed, 27 Mar 2019 21:52:05 +0000 (22:52 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 27 Mar 2019 21:53:14 +0000 (22:53 +0100)
Fixes d6fa04a437 ("IB: include SUPPORTED_DEVICES in 'make info' output")

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
scripts/target-metadata.pl

index 4e4bc73d9183905a7fcf3f4604efba9754848e1e..bd73ee910cdaeaf4f46917f14e6081be4a2d3e21 100755 (executable)
@@ -423,7 +423,7 @@ sub gen_profile_mk() {
                foreach my $profile (@{$cur->{profiles}}) {
                        print $profile->{id}.'_NAME:='.$profile->{name}."\n";
                        print $profile->{id}.'_HAS_IMAGE_METADATA:='.$profile->{has_image_metadata}."\n";
-                       if (@{$profile->{supported_devices}} > 0) {
+                       if (defined($profile->{supported_devices}) and @{$profile->{supported_devices}} > 0) {
                                print $profile->{id}.'_SUPPORTED_DEVICES:='.join(' ', @{$profile->{supported_devices}})."\n";
                        }
                        print $profile->{id}.'_PACKAGES:='.join(' ', @{$profile->{packages}})."\n";