include: declare variables formerly set in tmp/.host.mk
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 5 Feb 2015 16:57:18 +0000 (16:57 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 5 Feb 2015 16:57:18 +0000 (16:57 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44272

rules.mk

index 70768f055d009bc214946322e17c12b6978b927a..e5f681aeb22a3f9f7ac2efae16c9d16a9505192f 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -210,6 +210,12 @@ CP:=cp -fpR
 LN:=ln -sf
 XARGS:=xargs -r
 
+BASH:=$(STAGING_DIR_HOST)/bin/bash
+TAR:=$(STAGING_DIR_HOST)/bin/tar
+FIND:=$(STAGING_DIR_HOST)/bin/find
+PATCH:=$(STAGING_DIR_HOST)/bin/patch
+PYTHON:=$(STAGING_DIR_HOST)/bin/python
+
 INSTALL_BIN:=install -m0755
 INSTALL_DIR:=install -d -m0755
 INSTALL_DATA:=install -m0644