ath10k-ct: Enable DFS when "Enable DFS support" is set for kmod-ath
authorAndy Strohman <andrew@andrewstrohman.com>
Sun, 18 Dec 2016 19:06:06 +0000 (11:06 -0800)
committerFelix Fietkau <nbd@nbd.name>
Tue, 20 Dec 2016 15:24:22 +0000 (16:24 +0100)
This allows users of this package to configure DFS channels.
It mimics the behaviour of the ath10k module included in
package mac80211

Signed-off-by: Andy Strohman <andrew@andrewstrohman.com>
package/kernel/ath10k-ct/Makefile

index c5e504512481576341fb60ced349cf5e32ece767..97f284efbfd0f614f96c303334546732f98da0b2 100644 (file)
@@ -61,6 +61,10 @@ ifdef CONFIG_PACKAGE_ATH_DEBUG
   NOSTDINC_FLAGS += -DCONFIG_ATH10K_DEBUG
 endif
 
+ifdef CONFIG_PACKAGE_ATH_DFS
+  NOSTDINC_FLAGS += -DCONFIG_ATH10K_DFS_CERTIFIED
+endif
+
 define Build/Configure
        cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
 endef