include: Add nomips16 CPU_SUBTYPE
authorHauke Mehrtens <hauke.mehrtens@intel.com>
Tue, 14 Mar 2017 17:55:03 +0000 (18:55 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 20 Mar 2017 21:04:45 +0000 (22:04 +0100)
This can be used to indicate that a target does not support the optional mips16
extension even when it is a mips32r2 or later CPU.

This will generate a separate toolchain and a separate package folder,
e.g. mips_24kc_nomips16

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
include/target.mk

index 5490d4882f4c4a869ab4444f8afb408dfd6b4984..61489cabe707225d25d89d210700ce76ce810a8c 100644 (file)
@@ -258,7 +258,9 @@ ifeq ($(DUMP),1)
       FEATURES += virtio
     endif
     ifneq ($(CONFIG_CPU_MIPS32_R2),)
-      FEATURES += mips16
+      ifneq ($(CPU_SUBTYPE),nomips16)
+        FEATURES += mips16
+      endif
     endif
     FEATURES += $(foreach v,6 7,$(if $(CONFIG_CPU_V$(v)),arm_v$(v)))