set the PROFILE variable in target.mk appropriately
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 Mar 2007 23:13:52 +0000 (23:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 Mar 2007 23:13:52 +0000 (23:13 +0000)
SVN-Revision: 6470

include/target.mk

index bd3ceb955b7f00d0f76eb6d6305a2d9be5bd5e68..d0f7b9bc2b597c395caa95e1fcc237c90ffb96e2 100644 (file)
@@ -7,6 +7,12 @@
 
 include $(TMP_DIR)/.target.mk
 
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
+    PROFILE=$(1)
+  endif
+endef
+
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@