rules.mk: provide a macro "file_copy" which removes any symlink in the destination...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 2 Dec 2012 12:20:34 +0000 (12:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 2 Dec 2012 12:20:34 +0000 (12:20 +0000)
SVN-Revision: 34437

rules.mk

index 36bd22cac7b547e3d705d4e6fbe53fd46a700f3a..7139f79ef87511d7df2b32db07acccccfc15f461 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -287,6 +287,24 @@ define locked
                -c '$(subst ','\'',$(1))'
 endef
 
+# Recursively copy paths into another directory, purge dangling
+# symlinks before.
+# $(1) => File glob expression
+# $(2) => Destination directory
+define file_copy
+       for src_dir in $(sort $(foreach d,$(wildcard $(1)),$(dir $(d)))); do \
+               ( cd $$src_dir; find -type f -or -type d ) | \
+                       ( cd $(2); while :; do \
+                               read FILE; \
+                               [ -z "$$FILE" ] && break; \
+                               [ -L "$$FILE" ] || continue; \
+                               echo "Removing symlink $(2)/$$FILE"; \
+                               rm -f "$$FILE"; \
+                       done; ); \
+       done; \
+       $(CP) $(1) $(realpath $(2)/)/
+endef
+
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))