kernel: add missing snd-hda-intel module for Linux 3.18 and 4.1
authorJo-Philipp Wich <jo@mein.io>
Tue, 4 Oct 2016 22:43:10 +0000 (00:43 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 4 Oct 2016 22:45:12 +0000 (00:45 +0200)
Prior to kernel 4.4, the hda-intel module depends on the hda-controller
utility submodule so bundle it for the older kernel versions.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/sound.mk

index 13b0bb0dfe9dbea3d87946044787a6a94a4967b1..2f3e79f55af788483950afada24a5751d93665d2 100644 (file)
@@ -507,8 +507,9 @@ define KernelPackage/sound-hda-intel
        CONFIG_SOUND_PCI \
        CONFIG_SND_HDA_INTEL
   FILES:= \
-       $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko
-  AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
+       $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
+       $(LINUX_DIR)/sound/pci/hda/snd-hda-controller.ko@lt4.4
+  AUTOLOAD:=$(call AutoProbe,snd-hda-controller@lt4.4 snd-hda-intel)
   $(call AddDepends/sound,kmod-sound-hda-core)
 endef