kernel: crypto-aead depends on crypto-null in 4.3 as well
authorFelix Fietkau <nbd@openwrt.org>
Fri, 11 Dec 2015 19:21:49 +0000 (19:21 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 11 Dec 2015 19:21:49 +0000 (19:21 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47870

package/kernel/linux/modules/crypto.mk

index fe64db46f732a887878f7912cf679ad5aba4b950..dc817eed5fe767f3a40b2569ac355029b144466c 100644 (file)
@@ -27,7 +27,7 @@ define KernelPackage/crypto-aead
        CONFIG_CRYPTO_AEAD2
   FILES:=$(LINUX_DIR)/crypto/aead.ko
   AUTOLOAD:=$(call AutoLoad,09,aead,1)
        CONFIG_CRYPTO_AEAD2
   FILES:=$(LINUX_DIR)/crypto/aead.ko
   AUTOLOAD:=$(call AutoLoad,09,aead,1)
-  $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
+  $(call AddDepends/crypto, +LINUX_4_3:kmod-crypto-null +LINUX_4_4:kmod-crypto-null)
 endef
 
 $(eval $(call KernelPackage,crypto-aead))
 endef
 
 $(eval $(call KernelPackage,crypto-aead))