kernel: update linux 3.8 to 3.8.11
authorGabor Juhos <juhosg@openwrt.org>
Wed, 1 May 2013 22:15:18 +0000 (22:15 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 1 May 2013 22:15:18 +0000 (22:15 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 36507

32 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.8/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.8/721-phy_packets.patch
target/linux/generic/patches-3.8/902-debloat_proc.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/mvebu/patches-3.8/004-net_mvneta_fix_driver_operations_smp.patch [deleted file]
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/x86/geos/target.mk
target/linux/xburst/Makefile

index 2505446088aad3f097425304f4803a9abca78c18..9575fbe8ce63cdac24fdf14d3c39caf366a90cc7 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.10)
-  LINUX_KERNEL_MD5SUM:=3d5fb6d9add9cce7725bbe9b139c8d6e
+ifeq ($(LINUX_VERSION),3.8.11)
+  LINUX_KERNEL_MD5SUM:=3c4f4fc96bf702d1e9dfbf4d4b4cde9d
 endif
 ifeq ($(LINUX_VERSION),3.9)
   LINUX_KERNEL_MD5SUM:=4348c9b6b2eb3144d601e87c19d5d909
index 3b50ba037539a1d349ca45aa97afe302a51ef7b1..2285bf026113790843f492db74353e8da1c08618 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index baaccdaa821b822b05139d089c04ffa7a49305ec..3ce41a4c91aa647a6a3b6aa1152e06b8945d4244 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 8c2a18280359d2a0addf1c3bca3cfccf1aef5fe8..19c1c72f75f9d761eaea2bbbbf8ccf036d099b0b 100644 (file)
  /*
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3868,13 +3868,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3896,13 +3896,14 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
  #include <asm/uaccess.h>
  
  #include <linux/proc_fs.h>
-@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
+@@ -764,10 +765,10 @@ static void tcp_v6_send_response(struct
        topt = (__be32 *)(t1 + 1);
  
        if (ts) {
index 38e2b0324371d32c1272dec07d348517f82a59a2..03589b40c7ecaffa96c6c222ceac244d7e2a144c 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index f0c1345dcab054351c6af532de76b19e25e2261a..c7e9f84e438b0fb89ce8bc62949ae010c03db9b8 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 38948ce6aad4e846f92561b185fa4723f61e1c04..c26d84dcb231b54ca0b36712619e5140e511404c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 7ce5082554bf837a1b4ae1d29c328cc7baf5f13a..f61867dbd456c3b6cf2e4420757bcd16cd3e64bd 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 09410b5cef7b0ef27955a72f2d7f0f888af1d301..cb489e89c1c1354e9a79144bc2835528719ef6c5 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index a33c61da85f22d3c0c0640116e841ebfbcaee488..6afca67b7c48009a06bf57754ee4cd74a6a4104d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 15422237f0d7d5c511581bf3b318e7c5ffe3913c..40e5d4efe315500f90b550b40c6a8966d21cb3cc 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 0b36548a965c2668ce9cd3fefe78a17977b481ba..3e42ac43316a7e039fa325d2ab939806c06a95fb 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 DEVICE_TYPE:=developerboard
 
index f4aafca45c251818406e40d551e21040ee6bc4d8..9fad8b991a3f54447a862362325b6a924f25f43e 100644 (file)
@@ -49,7 +49,7 @@
  
  int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
                    unsigned char banned_flags)
-@@ -4941,6 +4940,9 @@ int __init addrconf_init(void)
+@@ -4968,6 +4967,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -59,7 +59,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -4959,6 +4961,9 @@ void addrconf_cleanup(void)
+@@ -4986,6 +4988,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;
  
index 88b5969f395164e29ad71ac93a7734f7e0f2ae5b..d17f16ede9f3a9f19af8b6a41ee86d8331567485 100644 (file)
@@ -79,7 +79,7 @@
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -2360,9 +2360,19 @@ int dev_hard_start_xmit(struct sk_buff *
+@@ -2364,9 +2364,19 @@ int dev_hard_start_xmit(struct sk_buff *
                if (!list_empty(&ptype_all))
                        dev_queue_xmit_nit(skb, dev);
  
                if (rc == NETDEV_TX_OK)
                        txq_trans_update(txq);
                return rc;
-@@ -2385,9 +2395,19 @@ gso:
+@@ -2389,9 +2399,19 @@ gso:
                if (!list_empty(&ptype_all))
                        dev_queue_xmit_nit(nskb, dev);
  
index 650b3c2d05ee18f2a0e2244f33bddc13c3b8a934..2489164189c3923973858545dfa832f9eec5391d 100644 (file)
                goto err;
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4584,9 +4584,11 @@ static int __net_init dev_proc_net_init(
+@@ -4588,9 +4588,11 @@ static int __net_init dev_proc_net_init(
  
        if (!proc_net_fops_create(net, "dev", S_IRUGO, &dev_seq_fops))
                goto out;
                goto out_softnet;
  
        if (wext_proc_init(net))
-@@ -4595,9 +4597,11 @@ static int __net_init dev_proc_net_init(
+@@ -4599,9 +4601,11 @@ static int __net_init dev_proc_net_init(
  out:
        return rc;
  out_ptype:
  out_dev:
        proc_net_remove(net, "dev");
        goto out;
-@@ -4607,8 +4611,10 @@ static void __net_exit dev_proc_net_exit
+@@ -4611,8 +4615,10 @@ static void __net_exit dev_proc_net_exit
  {
        wext_proc_exit(net);
  
index bcd0ff79fa6a34bf298a3d7c5220aa413c103ae5..2e6573d3dd122318a1b27881f39fe0373394fe42 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index 5e4d2c132d3447fa51d4d2d4621ea1f7fe84f39f..c074f658ff44d0e6776bde396e083049b2e9e353 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 DEVICE_TYPE:=developerboard
 
index 94fe5f79252d108c1227cefc9831fc1b177e4c4f..ddc41262550969abafd75dee5b897bd6ec912349 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 7b5a7ac5d4b89d4a85906c4c8a0bee915ffc1555..035ed1bd47c55c8500e85c82e5fd4742c58a72f6 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 3129d188f0c3dc4b82ba444a24121ad26b082e66..340db60f27b1d769e51900decea1b2eb5c07553c 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index b6f917f40197f3cea7fa17d1dec0c1461db3c2a0..815aeba85bedde753486758715eb853e36766dde 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/mvebu/patches-3.8/004-net_mvneta_fix_driver_operations_smp.patch b/target/linux/mvebu/patches-3.8/004-net_mvneta_fix_driver_operations_smp.patch
deleted file mode 100644 (file)
index d1a8e42..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-From: Dmitri Epshtein <dima@marvell.com>
-
-In order for the driver to behave properly in a SMP context, the same
-transmit queue should be used by the kernel in dev_queue_xmit() and in
-the driver's mvneta_tx() function. To achieve that, the driver now
-implements the ->ndo_select_txq() operation.
-
-For now, it always returns the same transmit queue, txq_def, until the
-driver is expanded to properly take advantage of the multiqueue
-capabilities of the hardware.
-
-Without this patch, the network driver crashes the kernel almost
-immediately on Armada XP platforms, if the network load is at least a
-little bit parallel (i.e several threads).
-
-[Thomas Petazzoni: reword commit message]
-Signed-off-by: Dmitri Epshtein <dima@marvell.com>
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
-This is 3.8-rc material.
----
- drivers/net/ethernet/marvell/mvneta.c |   17 +++++++++++++++--
- 1 file changed, 15 insertions(+), 2 deletions(-)
-
---- a/drivers/net/ethernet/marvell/mvneta.c
-+++ b/drivers/net/ethernet/marvell/mvneta.c
-@@ -1310,6 +1310,17 @@ static u32 mvneta_skb_tx_csum(struct mvn
-       return MVNETA_TX_L4_CSUM_NOT;
- }
-+static u16 mvneta_tx_policy(struct mvneta_port *pp, struct sk_buff *skb)
-+{
-+      return (u16)txq_def;
-+}
-+
-+static u16 mvneta_select_txq(struct net_device *dev, struct sk_buff *skb)
-+{
-+      struct mvneta_port *pp = netdev_priv(dev);
-+      return mvneta_tx_policy(pp, skb);
-+}
-+
- /* Returns rx queue pointer (find last set bit) according to causeRxTx
-  * value
-  */
-@@ -1476,7 +1487,8 @@ error:
- static int mvneta_tx(struct sk_buff *skb, struct net_device *dev)
- {
-       struct mvneta_port *pp = netdev_priv(dev);
--      struct mvneta_tx_queue *txq = &pp->txqs[txq_def];
-+      u16 txq_id = mvneta_tx_policy(pp, skb);
-+      struct mvneta_tx_queue *txq = &pp->txqs[txq_id];
-       struct mvneta_tx_desc *tx_desc;
-       struct netdev_queue *nq;
-       int frags = 0;
-@@ -1486,7 +1498,7 @@ static int mvneta_tx(struct sk_buff *skb
-               goto out;
-       frags = skb_shinfo(skb)->nr_frags + 1;
--      nq    = netdev_get_tx_queue(dev, txq_def);
-+      nq    = netdev_get_tx_queue(dev, txq_id);
-       /* Get a descriptor for the first part of the packet */
-       tx_desc = mvneta_txq_next_desc_get(txq);
-@@ -2550,6 +2562,7 @@ static const struct net_device_ops mvnet
-       .ndo_change_mtu      = mvneta_change_mtu,
-       .ndo_tx_timeout      = mvneta_tx_timeout,
-       .ndo_get_stats64     = mvneta_get_stats64,
-+      .ndo_select_queue    = mvneta_select_txq,
- };
- const struct ethtool_ops mvneta_eth_tool_ops = {
index adc01938b7c4c2ec1e54c59c32a472cef2e3b3d8..cefea839775501062d4743e58b777a42a1f83029 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index fceccdf093cf04230faf440977a8334697119229..06047da8f94e1cda8112ec208aff64bd2107d054 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index f4a42127656c1c84e9cc98cb8777de8a73d1acf4..1118923d5d96a0155721e26b43d7345788fa4eae 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 52441810e5232587a490fcb26dc2c10afb20a64d..2dbfc36e5e31eb1587a700f16f89a00126c08a0e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index ce5571f07ecf6c1adf3181dc074a9aabb986e7f0..f92bc47ac3f122509014df0adfedbbc1bf996c93 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 DEVICE_TYPE:=developerboard
 
index c9066544244d34d6a8ab465aa86a8415dfccfb86..e6fd3615760e338880dc1f2939a6fe3cd23017c1 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
index ff4c29d6ef6b285da0a0b7780f2feca37e4ba869..9588949797b14786fa2dc477fb0521fe254ac8c1 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 765d7085090c418d7d95c3e9fc6d59a403931738..5d384a1238d78bca63168761bd2b01ec3ef87f96 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 define Target/Description
        Build firmware images for x86 based boards
index 89a356f05d3dc7d90acba41c32f6a699215ab5a8..30930e9a7fbe6f15476fb3945e75cc17c0a601ab 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index f90c8ecf60eb35182481d93070bfe75646f7c8c6..13c4c6f0aaafc30ebf78326063c0185262114d24 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
 
 DEVICE_TYPE=other