ath79: add support for devolo WiFi pro 1750i
authorDavid Bauer <mail@david-bauer.net>
Tue, 1 Jan 2019 18:17:22 +0000 (19:17 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 5 Jan 2019 20:55:22 +0000 (21:55 +0100)
Hardware
--------
CPU:   Qualcomm Atheros QCA9558
RAM:   128M DDR2
FLASH: 16MiB
ETH:   1x Atheros AR8035 (PoE in)
WiFi2: QCA9558 3T3R
WiFi5: QCA9880 3T3R
BTN:   1x Reset
LED:   1x LED blue
       1x LED red
BEEP:  1x GPIO attached piezo beeper
UART:  3.3V GND TX RX (115200-N-8) (3.3V is square pad)
       Header is located next to reset-button

Installation
------------
Make sure you set a password for the root user as prompted on first
setup!

1. Upload OpenWRT sysupgrade image via SSH to the device.
Use /tmp as the destination folder on the device.
User is root, password the one set in the web interface.

2. Install OpenWRT with

> sysupgrade -n -F /tmp/<openwrt-image-name>

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_devolo_dvl1750i.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 97d139010621baa331007020bd1a4d9ed39bfe44..0b1a5f39a15f2d7f34a7278f700c3b3c716109b2 100755 (executable)
@@ -11,6 +11,7 @@ ath79_setup_interfaces()
        case "$board" in
        avm,fritz300e|\
        devolo,dvl1750c|\
+       devolo,dvl1750i|\
        ocedo,koala|\
        ocedo,raccoon|\
        pcs,cap324|\
index faee7819700f00f756107b2719949d0445e5b214..9fc0f80569b0dc900001c6008ee0270e93559899 100644 (file)
@@ -88,7 +88,8 @@ case "$FIRMWARE" in
 "ath10k/cal-pci-0000:00:00.0.bin")
        case $board in
        devolo,dvl1200e|\
-       devolo,dvl1750c)
+       devolo,dvl1750c|\
+       devolo,dvl1750i)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary art 0) -1)
                ;;
diff --git a/target/linux/ath79/dts/qca9558_devolo_dvl1750i.dts b/target/linux/ath79/dts/qca9558_devolo_dvl1750i.dts
new file mode 100644 (file)
index 0000000..bd3702e
--- /dev/null
@@ -0,0 +1,51 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_devolo_dvl1xxx.dtsi"
+
+/ {
+       compatible = "devolo,dvl1750i", "qca,qca9557";
+       model = "devolo WiFi pro 1750i";
+
+       aliases {
+               led-boot = &status_blue;
+               led-failsafe = &status_red;
+               led-running = &status_blue;
+               led-upgrade = &status_red;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               status_blue: status_blue {
+                       label = "dvl1750i:blue:status";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               status_red: status_red {
+                       label = "dvl1750i:red:status";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       beeper {
+               compatible = "gpio-beeper";
+               gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;
+       };
+};
+
+&eth0 {
+       pll-data = <0xbe000000 0x80000101 0x80001313>;
+};
+
+&gmac_config {
+       rxdv-delay = <3>;
+       rxd-delay = <3>;
+       txen-delay = <3>;
+       txd-delay = <3>;
+       rgmii-enabled = <1>;
+};
index 858c1662ccc62f41c336365b412d6ecfadb32aed..438a842182f1cd1b10830a87ba79ca116bb420ee 100644 (file)
@@ -178,6 +178,14 @@ define Device/devolo_dvl1750c
 endef
 TARGET_DEVICES += devolo_dvl1750c
 
+define Device/devolo_dvl1750i
+  ATH_SOC := qca9558
+  DEVICE_TITLE := devolo WiFi pro 1750i
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750i
+
 define Device/dlink_dir-825-b1
   ATH_SOC := ar7161
   DEVICE_TITLE := D-LINK DIR-825 B1