ppc40x: build initramfs images for the OpenRB/Magicbox boards
authorGabor Juhos <juhosg@openwrt.org>
Sun, 18 Apr 2010 08:32:35 +0000 (08:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 18 Apr 2010 08:32:35 +0000 (08:32 +0000)
SVN-Revision: 20980

target/linux/ppc40x/image/Makefile

index 3e355a98e743d81a8a1b6fb876a407bd0ebe3ba6..415539e9cc0ad00b4d892ed9d3371594dfde5918 100644 (file)
@@ -16,6 +16,7 @@ endef
 
 define Image/BuildKernel
        cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+       $(call Image/Build/Initramfs)
 endef
 
 define Image/Build
@@ -62,4 +63,11 @@ define Image/Build/squashfs
        ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
 endef
 
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+define Image/Build/Initramfs
+       cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox $(BIN_DIR)/openwrt-$(BOARD)-magicbox-initramfs.bin
+       cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb $(BIN_DIR)/openwrt-$(BOARD)-openrb-initramfs.bin
+endef
+endif
+
 $(eval $(call BuildImage))