mac80211: when looking for VHT, check 5GHz support as well
authorImre Kaloz <kaloz@openwrt.org>
Fri, 20 Mar 2015 11:47:16 +0000 (11:47 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 20 Mar 2015 11:47:16 +0000 (11:47 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 44906

package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/wifi/mac80211.sh

index 589b0cb1bd071a4c7c851c127d6588b57c43e6b3..d71417ec35edcd94524881ecf64ee8fca04132d5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2014 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2015-03-09
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_BACKPORT_VERSION:=
 PKG_MD5SUM:=6d4b04e4ce8a1f54dabfb04f4709453c
index a7c4d2dbc2bce08b95ee3f5bbaf86a6d01180a2f..ff0d467ab15eb580423b050fc7b589b412e705da 100644 (file)
@@ -86,7 +86,8 @@ detect_mac80211() {
                iw phy "$dev" info | grep -q '2412 MHz' || { mode_band="a"; channel="36"; }
 
                vht_cap=$(iw phy "$dev" info | grep -c 'VHT Capabilities')
-               [ "$vht_cap" -gt 0 ] && {
+               5ghz_cap=$(iw phy "$dev" info | grep -c "Band 2")
+               [ "$vht_cap" -gt 0 -a "$5ghz_cap" -gt 0 ] && {
                        mode_band="a";
                        channel="36"
                        htmode="VHT80"