madwifi: fix x86_64 compilation
authorFelix Fietkau <nbd@openwrt.org>
Fri, 12 Sep 2008 19:55:38 +0000 (19:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 12 Sep 2008 19:55:38 +0000 (19:55 +0000)
SVN-Revision: 12574

package/madwifi/patches/106-get_arch.patch [new file with mode: 0644]

diff --git a/package/madwifi/patches/106-get_arch.patch b/package/madwifi/patches/106-get_arch.patch
new file mode 100644 (file)
index 0000000..b5ef4f2
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/scripts/get_arch.mk
++++ b/scripts/get_arch.mk
+@@ -36,6 +36,13 @@
+ $(Cannot determine ARCH)
+ endif
++# Allow ARCH to be x86
++ifneq (,$(CONFIG_X86))
++ifeq (x86,$(ARCH))
++ARCH-y = $(ARCH)
++endif
++endif
++
+ # Don't allow ARCH to be overridden by a different value.
+ ifeq (,$(ARCH))
+ ARCH = $(ARCH-y)