kernel: update 3.14 to 3.14.11
authorLuka Perkov <luka@openwrt.org>
Tue, 8 Jul 2014 22:44:34 +0000 (22:44 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 8 Jul 2014 22:44:34 +0000 (22:44 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 41551

include/kernel-version.mk
target/linux/generic/patches-3.14/550-ubifs-symlink-xattr-support.patch
target/linux/generic/patches-3.14/810-pci_disable_common_quirks.patch
target/linux/mvebu/Makefile
target/linux/x86_64/Makefile

index 4fc48bf9c19f4da4e2452e2bde4239278f80b914..f72ad424b616d50aad6c24743251044b6594d579 100644 (file)
@@ -23,8 +23,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14.10)
-  LINUX_KERNEL_MD5SUM:=3ca34a93c59a788d7f573b2660eb5342
+ifeq ($(LINUX_VERSION),3.14.11)
+  LINUX_KERNEL_MD5SUM:=88b82f8d7a1b04e5cde268e286728226
 endif
 
 # disable the md5sum check for unknown kernel versions
index 9ca8ac140942a1d0f15ed587fdd76f254e631e50..0235340aa875b943c8566588f633f06191344e00 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/ubifs/file.c
 +++ b/fs/ubifs/file.c
-@@ -1577,6 +1577,10 @@ const struct inode_operations ubifs_syml
+@@ -1576,6 +1576,10 @@ const struct inode_operations ubifs_syml
        .follow_link = ubifs_follow_link,
        .setattr     = ubifs_setattr,
        .getattr     = ubifs_getattr,
index 8877bc0d42f98512d800eb397dce49ef207fefa4..e4becb38d8a08240a44b34d623bb34ab989d5b91 100644 (file)
@@ -40,9 +40,9 @@
  /*
   * Some BIOS implementations leave the Intel GPU interrupts enabled,
   * even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -2950,6 +2954,8 @@ static void disable_igfx_irq(struct pci_
- DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0102, disable_igfx_irq);
+@@ -2951,6 +2955,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
+ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
  
 +#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
 +
index 0252849c06083ae0255f318055397452a4025cca..a2d78df586f497260d7caa7429e68a9908252750 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.14.10
+LINUX_VERSION:=3.14.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 600401207d44d0b296d39a8e35f7c267f3ce5cee..a029719de1d54dbb023c1ad557b8fc3acb1175ee 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.10
+LINUX_VERSION:=3.14.11
 
 KERNELNAME:=bzImage