tools: drop circular dependency between patch and ccache, build patch without ccache...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 20 Jul 2015 10:50:46 +0000 (10:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 20 Jul 2015 10:50:46 +0000 (10:50 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 46434

tools/Makefile
tools/patch/Makefile

index 8b5dd6c5207945826085a65636f3a30609e8eb79..60041ddc31a8ac5e55f8126895f4f8149079992c 100644 (file)
@@ -73,7 +73,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/install
 $(curdir)/patchelf/compile := $(curdir)/libtool/install
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
 tools-y += ccache
 endif
 
index 94b36075929c699bf89d67fa519c383246e598b6..4774478c9650ddf7d9dc695c74fa3f16ec1b14a5 100644 (file)
@@ -15,4 +15,7 @@ PKG_MD5SUM:=e3da7940431633fb65a01b91d3b7a27a
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
 $(eval $(call HostBuild))