build: add -Wno-error=unused-result to target cflags
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Nov 2015 12:04:09 +0000 (12:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Nov 2015 12:04:09 +0000 (12:04 +0000)
Many glibc functions have __warn_unused_result__ in so many different
core functions, and failing the build for all of those simply does not
make any sense

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47440

rules.mk

index 348b45d6e19eea2036f29c13af3a2a6c8ba31e65..f749863d7cb8acc5d5899ea127bee8a5499e54cf 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -143,7 +143,7 @@ ifndef DUMP
     -include $(TOOLCHAIN_DIR)/info.mk
     export GCC_HONOUR_COPTS:=0
     TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))-)
-    TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable
+    TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result
     TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/usr/include
     ifeq ($(CONFIG_USE_MUSL),y)
       TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/include/fortify