odhcp6c: Make SLAAC-only work without reqprefix=no
authorSteven Barth <cyrus@openwrt.org>
Mon, 6 May 2013 10:20:43 +0000 (10:20 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 6 May 2013 10:20:43 +0000 (10:20 +0000)
Previously if the upstream router did not provide any DHCPv6-service
the wan6 interface would not come up even if RAs were received. The new
behavior allows the wan6 interface to comeup with RA-only configuration
after a timeout of 10s.

SVN-Revision: 36555

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script

index 298af3d7b9c7694516f4d15cc9adb625f040155d..140f27a31304b94452dff3523bca0ff6acfc2949 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-04-23
+PKG_VERSION:=2013-05-05
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=2515dbce13746bb1633cfa4b8e22424946a7f007
+PKG_SOURCE_VERSION:=493b90de720d198a988460bee83340dafbbfa10d
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index 56f8c39ca4fc550f5e3de739439e8d44e0f2f373..c81ffee65d686b2209f993764effc8c0bf76f9d3 100755 (executable)
@@ -78,7 +78,11 @@ teardown_interface() {
 }
 
 case "$2" in
-       informed|bound|updated|rebound|ra-updated)
+       bound)
+               teardown_interface "$1"
+               setup_interface "$1"
+       ;;
+       informed|updated|rebound|ra-updated)
                setup_interface "$1"
        ;;
        started|stopped|unbound)