kernel: Fix rtc-ds1307 dependency on hwmon-core for 4.19
authorPetr Štetiar <ynezz@true.cz>
Tue, 18 Dec 2018 10:08:16 +0000 (11:08 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 3 Jan 2019 17:05:47 +0000 (18:05 +0100)
It seems, that since Linux 4.18-rc1 rtc-ds1307 depends on hwmon-core.

 commit 6b583a64fd1e019fd01626b46892ebf2361951c5
 Author: Heiner Kallweit <hkallweit1@gmail.com>
 Date:   Wed Sep 27 22:41:26 2017 +0200

    rtc: ds1307: simplify hwmon config

    We don't have to define an extra config symbol, IS_REACHABLE does
    what we need. And having this config symbol just to save the few
    bytes of hwmon support on non-DS3231 chips isn't worth it IMO
    (especially as the symbol is set per default).

While at it, use the same dependency check for `kmod-regmap` as well, so
it's future proof as well.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/linux/modules/other.mk

index c521405040009c4cfd2e9b8eedbcacda8b8228d4..89dbcd0d0afcc0d1ef1e08973452bfdf76afc432 100644 (file)
@@ -476,7 +476,7 @@ define KernelPackage/rtc-ds1307
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
   DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
-  DEPENDS:=+kmod-i2c-core +LINUX_4_14:kmod-regmap
+  DEPENDS:=+kmod-i2c-core +!(LINUX_3_18||LINUX_4_9):kmod-regmap +!(LINUX_3_18||LINUX_4_9):kmod-hwmon-core
   KCONFIG:=CONFIG_RTC_DRV_DS1307 \
        CONFIG_RTC_CLASS=y
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko