fix inclusion of kernel modules selected for install in images (closes: #598).
authorNicolas Thill <nico@openwrt.org>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
SVN-Revision: 4081

openwrt/target/linux/rules.mk

index ae557f26b4a38449358f7efeeb0b9ce6f57c13de..e0307affd96453a18a69a007df67c86bc74e9dfb 100644 (file)
@@ -55,10 +55,10 @@ PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)_
 I_$(1) := $(KMOD_BUILD_DIR)/ipkg/$(2)
 
 ifeq ($$(KDEPEND_$(1)),m)
-ifneq ($(BR2_PACKAGE_KMOD_$(1)),)
+ifneq ($$(BR2_PACKAGE_KMOD_$(1)),)
 TARGETS += $$(PKG_$(1))
 endif
-ifeq ($(BR2_PACKAGE_KMOD_$(1)),y)
+ifeq ($$(BR2_PACKAGE_KMOD_$(1)),y)
 INSTALL_TARGETS += $$(PKG_$(1))
 endif
 endif