ramips: add support for easyacc wizard8800
authorJohn Crispin <john@openwrt.org>
Fri, 1 Aug 2014 11:19:50 +0000 (11:19 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 1 Aug 2014 11:19:50 +0000 (11:19 +0000)
Signed-off-by: Sebastian Wendel <s.wendel@sourceindex.de>
SVN-Revision: 41936

target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/dts/WIZARD8800.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 40c60fee5cf5121c639162e6209f79b5d84be21b..da7600c2c4580242e931e2e909493cacd4bd3ee5 100755 (executable)
@@ -55,6 +55,7 @@ ramips_setup_interfaces()
                 ucidef_set_interface_lan "eth0.2"
                 ;;
 
+       wizard8800 | \
        wl-330n | \
        wmr300)
                ucidef_set_interface_lan "eth0.1"
index f7e04b7391176c480ad257f795befdbf78d6461f..d188dd7bde817125def4053b0f8297c8c6929701 100755 (executable)
@@ -121,6 +121,9 @@ ramips_board_detect() {
        *"ESR-9753")
                name="esr-9753"
                ;;
+       *"EASYACC WI-STOR WIZARD 8800")
+               name="wizard8800"
+               ;;
        *"Edimax BR-6475nD")
                name="br-6475nd"
                ;;
diff --git a/target/linux/ramips/dts/WIZARD8800.dts b/target/linux/ramips/dts/WIZARD8800.dts
new file mode 100644 (file)
index 0000000..a80b937
--- /dev/null
@@ -0,0 +1,82 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "WIZARD8800", "ralink,rt5350-soc";
+       model = "EASYACC WI-STOR WIZARD 8800";
+
+       palmbus@10000000 {
+               gpio1@638 {
+                       status = "okay";
+               };
+
+               gpio2@660 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q32";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "w25q32";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x2f>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+};
index 62992cd607d080a73101b892b4b43e51de7f15a8..c8f1a433d996d9fda2bc705d80b2a7e52bd48680 100644 (file)
@@ -499,6 +499,8 @@ endef
 BuildFirmware/WHRG300N/initramfs=$(call BuildFirmware/OF/initramfs,$(1),whr-g300n,WHR-G300N)
 Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
 
+Image/Build/Profile/WIZARD8800=$(call BuildFirmware/Default8M/$(1),$(1),wizard-8800,WIZARD8800,Linux Kernel Image)
+
 Image/Build/Profile/WL_330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL_330N)
 
 Image/Build/Profile/WL_330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g,WL_330N3G)
@@ -617,6 +619,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
+       $(call Image/Build/Profile/WIZARD8800,$(1))
        $(call Image/Build/Profile/WL_330N,$(1))
        $(call Image/Build/Profile/WL_330N3G,$(1))
        $(call Image/Build/Profile/WL341V3,$(1))