build: use SNAPSHOT instead of CURRENT to designate untagged branch builds
authorJo-Philipp Wich <jo@mein.io>
Fri, 2 Dec 2016 21:11:40 +0000 (22:11 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 14 Dec 2016 17:43:49 +0000 (18:43 +0100)
Calling a build ##.##-CURRENT might mislead users into thinking that this
build is the most current release of a branch.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/version.mk
package/base-files/image-config.in

index a21bf25c7ff8be9b56b1e0ca07a537cc1e908f17..1a0d3c990b5db305b75f52f0ed5a4c9a23092888 100644 (file)
@@ -31,7 +31,7 @@ qstrip_escape=$(subst ','\'',$(call qstrip,$(1)))
 sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
 
 VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),CURRENT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
 
 VERSION_CODE:=$(call qstrip_escape,$(CONFIG_VERSION_CODE))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
index b18f2d85b128e354c7275c2625c50af83292d068..a8d82d3e0cfb9560d227e29a4671a8ecc9f68b13 100644 (file)
@@ -175,8 +175,8 @@ if VERSIONOPT
                prompt "Release version number"
                help
                        This is the release version number embedded in the image.
-                       If unspecified, it defaults to CURRENT for the master branch
-                       or to ##.##-CURRENT on release branches.
+                       If unspecified, it defaults to SNAPSHOT for the master branch
+                       or to ##.##-SNAPSHOT on release branches.
 
        config VERSION_CODE
                string
@@ -195,8 +195,8 @@ if VERSIONOPT
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
                         %R .. Repository revision ID
-                        %V .. Configured release version number or "CURRENT", uppercase
-                        %v .. Configured release version number or "current", lowercase
+                        %V .. Configured release version number or "SNAPSHOT", uppercase
+                        %v .. Configured release version number or "snapshot", lowercase
                         %C .. Configured release revision code or value of %R, uppercase
                         %c .. Configured release revision code or value of %R, lowercase
                         %N .. Release name, uppercase