busybox: move traceroute applets to /bin
authorDaniel Golle <daniel@makrotopia.org>
Wed, 19 Jul 2017 21:52:22 +0000 (23:52 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 30 Aug 2017 16:12:48 +0000 (18:12 +0200)
busybox currently installs traceroute and traceroute6 into /usr/bin
which prevents their 'full' iputils variants from being installed.
Move those applets to /bin so they can coexist with their iputils
siblings using the same PATH convention already applied for coreutils
and other drop-in 'full' versions.
Refresh existing patch while at it.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/utils/busybox/patches/230-add_nslookup_lede.patch
package/utils/busybox/patches/500-move-traceroute-applets-to-bin.patch [new file with mode: 0644]

index 976960cf1a69f67c2ed6f6313c8056905a2f5124..e394dfb9b9491c3aee4244230404ca5d9b97c230 100644 (file)
@@ -17,8 +17,6 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  2 files changed, 921 insertions(+)
  create mode 100644 networking/nslookup_lede.c
 
-diff --git a/Makefile.flags b/Makefile.flags
-index 65021de25..096ab7756 100644
 --- a/Makefile.flags
 +++ b/Makefile.flags
 @@ -134,6 +134,12 @@ else
@@ -34,9 +32,6 @@ index 65021de25..096ab7756 100644
  # libpam may use libpthread, libdl and/or libaudit.
  # On some platforms that requires an explicit -lpthread, -ldl, -laudit.
  # However, on *other platforms* it fails when some of those flags
-diff --git a/networking/nslookup_lede.c b/networking/nslookup_lede.c
-new file mode 100644
-index 000000000..c6c90ddf3
 --- /dev/null
 +++ b/networking/nslookup_lede.c
 @@ -0,0 +1,915 @@
@@ -955,6 +950,3 @@ index 000000000..c6c90ddf3
 +
 +      return rc;
 +}
--- 
-2.11.0
-
diff --git a/package/utils/busybox/patches/500-move-traceroute-applets-to-bin.patch b/package/utils/busybox/patches/500-move-traceroute-applets-to-bin.patch
new file mode 100644 (file)
index 0000000..7fa06a6
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/networking/traceroute.c
++++ b/networking/traceroute.c
+@@ -239,8 +239,8 @@
+ //config:       Add option -I to use ICMP ECHO instead of UDP datagrams.
+ /* Needs socket(AF_INET, SOCK_RAW, IPPROTO_ICMP), therefore BB_SUID_MAYBE: */
+-//applet:IF_TRACEROUTE(APPLET(traceroute, BB_DIR_USR_BIN, BB_SUID_MAYBE))
+-//applet:IF_TRACEROUTE6(APPLET(traceroute6, BB_DIR_USR_BIN, BB_SUID_MAYBE))
++//applet:IF_TRACEROUTE(APPLET(traceroute, BB_DIR_BIN, BB_SUID_MAYBE))
++//applet:IF_TRACEROUTE6(APPLET(traceroute6, BB_DIR_BIN, BB_SUID_MAYBE))
+ //kbuild:lib-$(CONFIG_TRACEROUTE) += traceroute.o
+ //kbuild:lib-$(CONFIG_TRACEROUTE6) += traceroute.o