tools: mkimage: provide dtc path during build
authorJo-Philipp Wich <jo@mein.io>
Thu, 19 Apr 2018 06:26:15 +0000 (08:26 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 19 Apr 2018 06:34:34 +0000 (08:34 +0200)
The new mkimage version requires a CONFIG_MKIMAGE_DTC_PATH variable to be
provided during build, in order to hardcode a path to a suitable DT
compiler executable.

Failure to do so will result in stray "sh: 1: -I: not found" errors when
invoking mkimage for FIT image generation.

Fix the issue by supplying "dtc" as CONFIG_MKIMAGE_DTC_PATH value during
build. As we intend our host utilities to be relocatable and since we're
already overriding PATH when invoking mkimage, an absolute path is not
required.

Fixes: b13e981d72 ("tools/mkimage: update to version 2018.03")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
tools/mkimage/Makefile

index c7e1dfd6720cb3c5f891c339e7815cafd1c7731f..d0ff5f7e3701d5dd08e6f05ee896d356d5c3c96e 100644 (file)
@@ -30,6 +30,7 @@ define Host/Compile
                HOSTCFLAGS="$(HOST_CFLAGS)" \
                HOSTLDFLAGS="$(HOST_LDFLAGS)" \
                no-dot-config-targets=tools-only \
+               CONFIG_MKIMAGE_DTC_PATH=dtc \
                CONFIG_FIT_SIGNATURE=y \
                tools-only
 endef