sdk: find kernel modules when KDIR is a symlink
authorKarl Vogel <karl.vogel@gmail.com>
Thu, 29 Nov 2018 08:07:21 +0000 (09:07 +0100)
committerKarl Vogel <karl.vogel@gmail.com>
Thu, 29 Nov 2018 08:36:14 +0000 (09:36 +0100)
The find statement would not return any results if the KDIR_BASE pointed to a
symlink. Ran into this issue due to a custom Kernel/Prepare that was installing
a symlink to the kernel directory.

The extra slash at the end fixes this scenario and does no harm for targets that
have a proper KDIR.

Signed-off-by: Karl Vogel <karl.vogel@gmail.com>
target/sdk/Makefile

index a9df8be7d22ddca2a64bfe2df7bb432b604bce58..95ac3be197588ff98c8c2b7daa8c8c850a91d22c 100644 (file)
@@ -83,7 +83,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
        mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
        $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
        $(TAR) -cf - -C $(TOPDIR) \
-               `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+               `cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \
                `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
                        -type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
                $(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \