use unexport instead of export to clear perforce variables
authorFelix Fietkau <nbd@openwrt.org>
Fri, 8 May 2009 15:35:27 +0000 (15:35 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 8 May 2009 15:35:27 +0000 (15:35 +0000)
SVN-Revision: 15708

include/toplevel.mk

index 2ee1518b8a8b4aff4121843aa6112c57ec5d0f9e..78a03d877f9173f754d6ee3cdb41a0e44800c88d 100644 (file)
@@ -27,10 +27,7 @@ export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DI
 export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 
 # prevent perforce from messing with the patch utility
-export P4PORT=
-export P4USER=
-export P4CONFIG=
-export P4CLIENT=
+unexport P4PORT P4USER P4CONFIG P4CLIENT
 
 # make sure that a predefined CFLAGS variable does not disturb packages
 export CFLAGS=