update heyu
authorFelix Fietkau <nbd@openwrt.org>
Fri, 3 Mar 2006 01:22:42 +0000 (01:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 3 Mar 2006 01:22:42 +0000 (01:22 +0000)
SVN-Revision: 3299

openwrt/package/heyu/Makefile
openwrt/package/heyu/patches/01-avoid_configure.patch

index 1adb7275b7fa5036ef4870d1e712d960ecc82bdb..195d119bbfa104de87b8fa3aad0bdce00697b67d 100644 (file)
@@ -3,10 +3,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=heyu
-PKG_VERSION:=2.0beta.2
-PKG_RELEASE:=2
-PKG_MD5SUM:=e8477bb068f79eb9cb81e7bb76235d22
-PKG_SOURCE_URL:=http://www.heyu.org/download
+PKG_VERSION:=2.0beta.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
+PKG_SOURCE_URL:=http://heyu.tanj.com/download/
 PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
index 894397ad867392ba8ff053edb4c79346d1163fdf..110602f5dc41336baa410c9988fe6a2aa13014d2 100644 (file)
@@ -16,7 +16,7 @@ diff -urN orig/heyu-2.0beta.2/Makefile heyu-2.0beta.2/Makefile
 +#          -DVOID       if compiler doesn't understand 'void'
 +
 +#This makefile is built for linux
-+DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ
++DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ -DHASCM17A
 +LIBS = -lm -lc
 +# # The rest of the makefile should need no changes
 +
@@ -28,16 +28,16 @@ diff -urN orig/heyu-2.0beta.2/Makefile heyu-2.0beta.2/Makefile
 +      monitor.c reset.c setclock.c stop.c \
 +      tty.c turn.c x10.c xread.c xwrite.c status.c cm11a.c \
 +      eeprom.c preset.c process.c sun.c cmd.c config.c x10state.c \
-+      poll.c modules.c
++      poll.c modules.c cm17a.c xsync.c timing.c
 +
 +OBJS =        date.o erase.o info.o message.o relay.o \
 +      monitor.o reset.o setclock.o stop.o \
 +      tty.o turn.o x10.o xread.o xwrite.o status.o cm11a.o \
 +      eeprom.o preset.o process.o sun.o cmd.o config.o x10state.o \
-+      poll.o modules.o
++      poll.o modules.o cm17a.o xsync.o timing.o
 +
 +OTHERSRC = README README2 Makefile x10config.sample protocol.txt eeprom.h \
-+      x10.sched.sample  monit x10biff heyu.1 x10.h x10config.5 \
++      x10.sched.sample  heyu.1 x10.h x10config.5 x10cm17a.5 \
 +      history.txt version.h heyufaq.txt x10sched.5 process.h sun.h \
 +      x10scripts.5 Configure Makefile.in install.sh INSTALL LICENSE
 +