ubi-utils: bump to version 1.5.1 for ubiblock support
authorJohn Crispin <john@openwrt.org>
Fri, 6 Jun 2014 09:34:47 +0000 (09:34 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 6 Jun 2014 09:34:47 +0000 (09:34 +0000)
ubiblock allows creating and removing read-only block devices
on top of ubi volumes.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 41033

package/utils/ubi-utils/Makefile
package/utils/ubi-utils/patches/130-lzma_jffs2.patch

index d009139246a4960c4fcec3093b9bee9104ef358b..fd41da064701cc306776dce47c32e792e0c447d4 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtd-utils
-PKG_REV:=ab8c6fb93ce9db0f09401c4b819b0b277dc00340
-PKG_VERSION:=1.5.0
-PKG_RELEASE:=2
+PKG_REV:=7d2839b8dede3ae368780364b4a07473d2303219
+PKG_VERSION:=1.5.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
@@ -33,6 +33,7 @@ include $(INCLUDE_DIR)/package.mk
 FILES:= \
        ubiattach \
        ubicrc32 \
+       ubiblock \
        ubidetach \
        ubiformat \
        ubimkvol \
index a40199eb6b913f2c7cc1b30b3060aa9502f18a91..c788f25d29ad7461b10ce1e3f8b78f5c3793f121 100644 (file)
@@ -2,10 +2,10 @@
 +++ b/Makefile
 @@ -3,7 +3,7 @@
  
- VERSION = 1.5.0
+ VERSION = 1.5.1
  
--CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS)
-+CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) -I./include/linux/lzma
+-CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS)
++CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS) -I./include/linux/lzma
  
  ifeq ($(WITHOUT_XATTR), 1)
    CPPFLAGS += -DWITHOUT_XATTR
 +}
 --- a/mkfs.jffs2.c
 +++ b/mkfs.jffs2.c
-@@ -1658,11 +1658,11 @@ int main(int argc, char **argv)
+@@ -1659,11 +1659,11 @@ int main(int argc, char **argv)
                                                  }
                                                  erase_block_size *= units;